summaryrefslogtreecommitdiff
path: root/net-libs/libtirpc/libtirpc-1.3.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libtirpc/libtirpc-1.3.3.ebuild')
-rw-r--r--net-libs/libtirpc/libtirpc-1.3.3.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/net-libs/libtirpc/libtirpc-1.3.3.ebuild b/net-libs/libtirpc/libtirpc-1.3.3.ebuild
index 46f43a6d7b8c..1533f24eee74 100644
--- a/net-libs/libtirpc/libtirpc-1.3.3.ebuild
+++ b/net-libs/libtirpc/libtirpc-1.3.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit multilib-minimal usr-ldscript
+inherit flag-o-matic multilib-minimal toolchain-funcs usr-ldscript
DESCRIPTION="Transport Independent RPC library (SunRPC replacement)"
HOMEPAGE="https://sourceforge.net/projects/libtirpc/ https://git.linux-nfs.org/?p=steved/libtirpc.git"
@@ -33,6 +33,13 @@ src_prepare() {
}
multilib_src_configure() {
+ # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
+ # https://github.com/gentoo/gentoo/pull/28355
+ # mold needs this too but right now tc-ld-is-mold is also not available
+ if tc-ld-is-lld; then
+ append-ldflags -Wl,--undefined-version
+ fi
+
local myeconfargs=(
$(use_enable kerberos gssapi)
$(use_enable static-libs static)