summaryrefslogtreecommitdiff
path: root/net-libs/libssh/libssh-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libssh/libssh-9999.ebuild')
-rw-r--r--net-libs/libssh/libssh-9999.ebuild27
1 files changed, 12 insertions, 15 deletions
diff --git a/net-libs/libssh/libssh-9999.ebuild b/net-libs/libssh/libssh-9999.ebuild
index d88693448ce5..19777b48ff39 100644
--- a/net-libs/libssh/libssh-9999.ebuild
+++ b/net-libs/libssh/libssh-9999.ebuild
@@ -3,7 +3,6 @@
EAPI=7
-MY_P="${PN}-${PV/_rc/rc}"
inherit cmake-multilib
DESCRIPTION="Access a working SSH implementation by means of a library"
@@ -13,7 +12,7 @@ if [[ "${PV}" == *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://git.libssh.org/projects/libssh.git"
else
- SRC_URI="https://www.libssh.org/files/$(ver_cut 1-2)/${MY_P}.tar.xz"
+ SRC_URI="https://www.libssh.org/files/$(ver_cut 1-2)/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
fi
@@ -43,8 +42,6 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS README ChangeLog )
-S="${WORKDIR}/${MY_P}"
-
PATCHES=( "${FILESDIR}/${PN}-0.8.0-tests.patch" )
src_prepare() {
@@ -54,34 +51,34 @@ src_prepare() {
cmake_comment_add_subdirectory examples
# keyfile torture test is currently broken
- sed -i \
- -e '/torture_keyfiles/d' \
- tests/unittests/CMakeLists.txt || die
+ sed -e "/torture_keyfiles/d" \
+ -i tests/unittests/CMakeLists.txt || die
# disable tests that take too long (bug #677006)
if use sparc; then
- sed -i \
- -e '/torture_threads_pki_rsa/d' \
- -e '/torture_pki_dsa/d' \
- tests/unittests/CMakeLists.txt || die
+ sed -e "/torture_threads_pki_rsa/d" -e "/torture_pki_dsa/d" \
+ -i tests/unittests/CMakeLists.txt || die
fi
+
+ sed -e "/^check_include_file.*HAVE_VALGRIND_VALGRIND_H/s/^/#DONT /" \
+ -i ConfigureChecks.cmake || die
}
multilib_src_configure() {
local mycmakeargs=(
- -DUNIT_TESTING="$(usex test)"
+ -DWITH_NACL=OFF
+ -DWITH_STACK_PROTECTOR=OFF
+ -DWITH_STACK_PROTECTOR_STRONG=OFF
-DWITH_DEBUG_CALLTRACE="$(usex debug)"
-DWITH_DEBUG_CRYPTO="$(usex debug)"
-DWITH_GCRYPT="$(usex gcrypt)"
-DWITH_GSSAPI="$(usex gssapi)"
-DWITH_MBEDTLS="$(usex mbedtls)"
- -DWITH_NACL=no
-DWITH_PCAP="$(usex pcap)"
-DWITH_SERVER="$(usex server)"
-DWITH_SFTP="$(usex sftp)"
- -DWITH_STACK_PROTECTOR=OFF
- -DWITH_STACK_PROTECTOR_STRONG=OFF
-DWITH_STATIC_LIB="$(usex static-libs)"
+ -DUNIT_TESTING="$(usex test)"
-DWITH_ZLIB="$(usex zlib)"
)