summaryrefslogtreecommitdiff
path: root/net-libs/libsoup
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libsoup')
-rw-r--r--net-libs/libsoup/Manifest2
-rw-r--r--net-libs/libsoup/libsoup-2.74.0.ebuild91
2 files changed, 93 insertions, 0 deletions
diff --git a/net-libs/libsoup/Manifest b/net-libs/libsoup/Manifest
index aeca2e9f6c63..bfabf811dbfd 100644
--- a/net-libs/libsoup/Manifest
+++ b/net-libs/libsoup/Manifest
@@ -1,4 +1,6 @@
AUX disable-apache-tests.patch 1318 BLAKE2B d922d5613241c96fed46c746dcd0fde704093f910ea4203a2cae8e8e11d141b8ef604292f36023e1b7f307b58b4352651aa0eb65d8a72cccc9040ec2c7940619 SHA512 3030472d05a4075349dabc21bb5fdab32a329a761e20d9e01b70d414a8de20ab9ecb6985376e61ebdc5378e5873bad42b8f3ef41cff4faf285a2593747195095
DIST libsoup-2.72.0.tar.xz 1477940 BLAKE2B e63a26aa29a4a34c4e4b0a2713818db52b206b04b56d99391648351f87a62dc3455020e8eb0312ef17b2b7d047a7d5731905ecc214085afd4eff25fefa30782b SHA512 ca16772d0d318c4be0c4859db1e32baffa2231b4732f3bf9814aa405febde86395a0fb8bfa1635d70a7b5853d2567403920b9b0d0f5c3c179294352af27e91de
+DIST libsoup-2.74.0.tar.xz 1498224 BLAKE2B c03b817a7a7f708480581aad258e5e24c541c6c2f39e48c51597d67c729b3a0722ef094916ad841904a0cafc67f12ad20d05b74ac41aeb174cb79b49fdd0977e SHA512 d78374c31631d7d1fb30ceb7c6016ab970cb321b06191d3463f178ceea9dacd08c828b8f16f5a30c185489ebfbc93ff9da09ae4978be3e3ff11bf7ee95a2a9a6
EBUILD libsoup-2.72.0-r1.ebuild 2935 BLAKE2B 4d611b5f77df37809765846aae89afe31af53b0d4dfb9b39e45e62dc9b91007442180b92c57e4cd57547d904ff3e6db9ab3ec5cebadbe54f10ba4dbd32ec70ec SHA512 b32dc99e460e040a6aa710d80363dd2fb5f462a36c1b7b79defda746456455e7b1cfce57f68a6bd6f7a940fb917e1ef5c1db1b538bde0637ce8cc0f7b20133c9
+EBUILD libsoup-2.74.0.ebuild 2942 BLAKE2B cac75b9dd4356c6fcc3a2745ce014ca3759d9e99a306f36b7972ee7e406dc45347b9f21437c83d98bf5dfc76ec593721410ff7c882f49775ae9a4046a6c0d810 SHA512 6b798d13d350cb6b9654ef6487a562e07916acf83ac0acfb12d8511575ed8d9ad6e5e228f59864a13de384aef5ec23526afe312950c428f48715feb2a4b53694
MISC metadata.xml 577 BLAKE2B ce68b60f9438bad0b1fb848dada28796f4c9a8f6ed119b29c26139bf7c146edb7e701f7565e425c27587a911e62bd1ed15cb6d120696ab1ac0f631f9f8145cc4 SHA512 a2937c0036d3decd995f8e83321b7b1e2bd9f6a5fe83ff7061dc1443ef5cfb4714d38c32689cd46065a7efbb5c8f120eed5ebfad650e7ccf4f1d98d9d45afb0d
diff --git a/net-libs/libsoup/libsoup-2.74.0.ebuild b/net-libs/libsoup/libsoup-2.74.0.ebuild
new file mode 100644
index 000000000000..5bf1131885f8
--- /dev/null
+++ b/net-libs/libsoup/libsoup-2.74.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome.org meson-multilib vala xdg
+
+DESCRIPTION="HTTP client/server library for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/libsoup"
+
+LICENSE="LGPL-2.1+"
+SLOT="2.4"
+
+# TODO: Default enable brotli at some point? But in 2.70.0 not advertised to servers yet - https://gitlab.gnome.org/GNOME/libsoup/issues/146
+IUSE="brotli gssapi gtk-doc +introspection samba ssl sysprof test +vala"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.58:2[${MULTILIB_USEDEP}]
+ >=dev-db/sqlite-3.8.2:3[${MULTILIB_USEDEP}]
+ >=dev-libs/libxml2-2.9.1-r4:2[${MULTILIB_USEDEP}]
+ brotli? ( >=app-arch/brotli-1.0.6-r1:=[${MULTILIB_USEDEP}] )
+ >=net-libs/libpsl-0.20[${MULTILIB_USEDEP}]
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4[${MULTILIB_USEDEP}] )
+ sys-libs/zlib
+ gssapi? ( virtual/krb5[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ samba? ( net-fs/samba )
+"
+RDEPEND="${DEPEND}
+ >=net-libs/glib-networking-2.38.2[ssl?,${MULTILIB_USEDEP}]
+"
+BDEPEND="
+ dev-libs/glib
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.20
+ app-text/docbook-xml-dtd:4.1.2 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+# test? ( www-servers/apache[ssl,apache2_modules_auth_digest,apache2_modules_alias,apache2_modules_auth_basic,
+# apache2_modules_authn_file,apache2_modules_authz_host,apache2_modules_authz_user,apache2_modules_dir,
+# apache2_modules_mime,apache2_modules_proxy,apache2_modules_proxy_http,apache2_modules_proxy_connect]
+# dev-lang/php[apache2,xmlrpc]
+# net-misc/curl
+# net-libs/glib-networking[ssl])"
+
+PATCHES=(
+ # Disable apache tests until they are usable on Gentoo, bug #326957
+ "${FILESDIR}"/disable-apache-tests.patch
+)
+
+src_prepare() {
+ use vala && vala_src_prepare
+ xdg_src_prepare
+ # https://gitlab.gnome.org/GNOME/libsoup/issues/159 - could work with libnss-myhostname
+ sed -e '/hsts/d' -i tests/meson.build || die
+}
+
+src_configure() {
+ # FIXME: we need addpredict to workaround bug #324779 until
+ # root cause (bug #249496) is solved
+ # But necessary while apache tests are disabled
+ #addpredict /usr/share/snmp/mibs/.index
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature gssapi)
+ -Dkrb5_config="${CHOST}-krb5-config"
+ $(meson_feature samba ntlm)
+ $(meson_feature brotli)
+ -Dntlm_auth="${EPREFIX}/usr/bin/ntlm_auth"
+ -Dtls_check=false # disables check, we still rdep on glib-networking
+ -Dgnome=false
+ $(meson_native_use_feature introspection)
+ $(meson_native_use_feature vala vapi)
+ $(meson_native_use_bool gtk-doc gtk_doc)
+ $(meson_use test tests)
+ -Dinstalled_tests=false
+ $(meson_feature sysprof)
+ )
+ meson_src_configure
+}