summaryrefslogtreecommitdiff
path: root/net-libs/libre-graph-api-cpp-qt-client/libre-graph-api-cpp-qt-client-1.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libre-graph-api-cpp-qt-client/libre-graph-api-cpp-qt-client-1.0.4.ebuild')
-rw-r--r--net-libs/libre-graph-api-cpp-qt-client/libre-graph-api-cpp-qt-client-1.0.4.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/net-libs/libre-graph-api-cpp-qt-client/libre-graph-api-cpp-qt-client-1.0.4.ebuild b/net-libs/libre-graph-api-cpp-qt-client/libre-graph-api-cpp-qt-client-1.0.4.ebuild
new file mode 100644
index 000000000000..51efb3492afb
--- /dev/null
+++ b/net-libs/libre-graph-api-cpp-qt-client/libre-graph-api-cpp-qt-client-1.0.4.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="API for cloud collaboration inspired by the MS Graph API"
+HOMEPAGE="https://github.com/owncloud/libre-graph-api-cpp-qt-client/"
+SRC_URI="https://github.com/owncloud/libre-graph-api-cpp-qt-client/archive/refs/tags/v${PV}.tar.gz -> libre-graph-api-cpp-qt-client-${PV}.tar.gz"
+
+S=${WORKDIR}/${P}/client
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="dev-qt/qtbase:6[gui,ssl]"
+RDEPEND="${DEPEND}"