summaryrefslogtreecommitdiff
path: root/net-libs/libquotient/files
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libquotient/files')
-rw-r--r--net-libs/libquotient/files/libquotient-0.7.0-no-android.patch29
-rw-r--r--net-libs/libquotient/files/libquotient-0.7.0-no-tests.patch34
2 files changed, 63 insertions, 0 deletions
diff --git a/net-libs/libquotient/files/libquotient-0.7.0-no-android.patch b/net-libs/libquotient/files/libquotient-0.7.0-no-android.patch
new file mode 100644
index 000000000000..f6cc8f838f1a
--- /dev/null
+++ b/net-libs/libquotient/files/libquotient-0.7.0-no-android.patch
@@ -0,0 +1,29 @@
+From 41299fe27a428bf02880865b7f8c1a7bee3f8ad5 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 3 Jan 2021 15:18:01 +0100
+Subject: [PATCH] Install EXPORT_ANDROID_MK only if(ANDROID)
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 523f5ae7..613e270c 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -381,7 +381,10 @@ install(FILES
+ "${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}/${PROJECT_NAME}ConfigVersion.cmake"
+ DESTINATION ${CMakeFilesLocation}
+ )
+-install(EXPORT_ANDROID_MK ${PROJECT_NAME}Targets DESTINATION ${CMAKE_INSTALL_DATADIR}/ndk-modules)
++
++if (ANDROID)
++ install(EXPORT_ANDROID_MK ${PROJECT_NAME}Targets DESTINATION ${CMAKE_INSTALL_DATADIR}/ndk-modules)
++endif ()
+
+ if (WIN32)
+ install(FILES mime/packages/freedesktop.org.xml DESTINATION mime/packages)
+--
+2.39.0
+
diff --git a/net-libs/libquotient/files/libquotient-0.7.0-no-tests.patch b/net-libs/libquotient/files/libquotient-0.7.0-no-tests.patch
new file mode 100644
index 000000000000..510b8a0a4d28
--- /dev/null
+++ b/net-libs/libquotient/files/libquotient-0.7.0-no-tests.patch
@@ -0,0 +1,34 @@
+From e5cc442f13aee922f6b2a954ad52b7aa8c558b2c Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sat, 24 Dec 2022 22:51:12 +0100
+Subject: [PATCH] Put Qt5Test dependency behind -DBUILD_TESTING
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 523f5ae7..9ae697b2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -93,7 +93,7 @@ else()
+ set(QtExtraModules "Multimedia") # See #483
+ endif()
+ string(REGEX REPLACE "^(.).*" "Qt\\1" Qt ${QtMinVersion}) # makes "Qt5" or "Qt6"
+-find_package(${Qt} ${QtMinVersion} REQUIRED Core Network Gui Test ${QtExtraModules})
++find_package(${Qt} ${QtMinVersion} REQUIRED Core Network Gui ${QtExtraModules})
+ get_filename_component(Qt_Prefix "${${Qt}_DIR}/../../../.." ABSOLUTE)
+ message(STATUS "Using Qt ${${Qt}_VERSION} at ${Qt_Prefix}")
+
+@@ -342,6 +342,7 @@ configure_file(${PROJECT_NAME}.pc.in ${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}
+ # Configure testing
+
+ if (BUILD_TESTING)
++ find_package(${Qt}Test ${QtMinVersion} REQUIRED)
+ enable_testing()
+ add_subdirectory(quotest)
+ add_subdirectory(autotests)
+--
+2.39.0
+