summaryrefslogtreecommitdiff
path: root/net-libs/libnftnl/libnftnl-1.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libnftnl/libnftnl-1.2.0.ebuild')
-rw-r--r--net-libs/libnftnl/libnftnl-1.2.0.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/net-libs/libnftnl/libnftnl-1.2.0.ebuild b/net-libs/libnftnl/libnftnl-1.2.0.ebuild
deleted file mode 100644
index 447974529f77..000000000000
--- a/net-libs/libnftnl/libnftnl-1.2.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools linux-info usr-ldscript
-
-DESCRIPTION="Netlink API to the in-kernel nf_tables subsystem"
-HOMEPAGE="https://netfilter.org/projects/nftables/"
-
-if [[ ${PV} =~ ^[9]{4,}$ ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://git.netfilter.org/${PN}"
-else
- SRC_URI="https://netfilter.org/projects/${PN}/files/${P}.tar.bz2"
- KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0/11" # libnftnl.so version
-IUSE="examples static-libs test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=net-libs/libmnl-1.0.4"
-BDEPEND="virtual/pkgconfig"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- if kernel_is ge 3 13; then
- CONFIG_CHECK="~NF_TABLES"
- linux-info_pkg_setup
- else
- eerror "This package requires kernel version 3.13 or newer to work properly."
- fi
-}
-
-src_prepare() {
- default
- [[ ${PV} =~ ^[9]{4,}$ ]] && eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_enable static-libs static)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- gen_usr_ldscript -a nftnl
- find "${ED}" -type f -name '*.la' -delete || die
-
- if use examples; then
- find examples/ -name 'Makefile*' -delete || die "Could not rm examples"
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}