summaryrefslogtreecommitdiff
path: root/net-libs/libnftnl/libnftnl-1.0.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libnftnl/libnftnl-1.0.5.ebuild')
-rw-r--r--net-libs/libnftnl/libnftnl-1.0.5.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/net-libs/libnftnl/libnftnl-1.0.5.ebuild b/net-libs/libnftnl/libnftnl-1.0.5.ebuild
new file mode 100644
index 000000000000..d581d38d35d9
--- /dev/null
+++ b/net-libs/libnftnl/libnftnl-1.0.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit base linux-info toolchain-funcs eutils
+
+DESCRIPTION="Netlink API to the in-kernel nf_tables subsystem"
+HOMEPAGE="http://netfilter.org/projects/nftables/"
+SRC_URI="http://netfilter.org/projects/${PN}/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="examples json static-libs test xml"
+
+RDEPEND=">=net-libs/libmnl-1.0.0
+ xml? ( >=dev-libs/mini-xml-2.6 )
+ json? ( >=dev-libs/jansson-2.3 )"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+REQUIRED_USE="test? ( json xml )"
+
+pkg_setup() {
+ if kernel_is ge 3 13; then
+ CONFIG_CHECK="~NF_TABLES"
+ linux-info_pkg_setup
+ else
+ eerror "This package requires kernel version 3.13 or newer to work properly."
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with xml xml-parsing) \
+ $(use_with json json-parsing)
+}
+
+src_install() {
+ default
+ gen_usr_ldscript -a nftnl
+ prune_libtool_files
+
+ if use examples; then
+ find examples/ -name 'Makefile*' -delete
+ dodoc -r examples/
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
+
+src_test() {
+ default
+ cd tests || die
+ ./test-script.sh || die
+}