summaryrefslogtreecommitdiff
path: root/net-libs/libident/libident-0.32-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libident/libident-0.32-r1.ebuild')
-rw-r--r--net-libs/libident/libident-0.32-r1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/net-libs/libident/libident-0.32-r1.ebuild b/net-libs/libident/libident-0.32-r1.ebuild
index e225b30168ef..5faec7595bc3 100644
--- a/net-libs/libident/libident-0.32-r1.ebuild
+++ b/net-libs/libident/libident-0.32-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,6 +12,9 @@ SRC_URI="http://people.via.ecp.fr/~rem/libident/${P}.tar.bz2"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 ~sparc x86"
+IUSE="test"
+# Interactive tests only.
+RESTRICT="!test? ( test ) test"
src_prepare() {
default
@@ -19,7 +22,9 @@ src_prepare() {
}
src_configure() {
- econf --disable-static
+ econf \
+ --disable-static \
+ $(use_enable test testers)
}
src_install() {