summaryrefslogtreecommitdiff
path: root/net-libs/libhtp/libhtp-0.5.31.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libhtp/libhtp-0.5.31.ebuild')
-rw-r--r--net-libs/libhtp/libhtp-0.5.31.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-libs/libhtp/libhtp-0.5.31.ebuild b/net-libs/libhtp/libhtp-0.5.31.ebuild
new file mode 100644
index 000000000000..d737b3ef282d
--- /dev/null
+++ b/net-libs/libhtp/libhtp-0.5.31.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="security-aware parser for the HTTP protocol and the related bits and pieces"
+HOMEPAGE="https://github.com/OISF/libhtp"
+SRC_URI="https://github.com/OISF/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+IUSE="debug static-libs"
+
+RDEPEND="sys-libs/zlib[static-libs?]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # The debug configure logic is broken.
+ ECONF_SOURCE=${S} \
+ econf \
+ $(usex debug '--enable-debug' '') \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die "Failed to remove .la files"
+ fi
+}