summaryrefslogtreecommitdiff
path: root/net-libs/libblkmaker/libblkmaker-0.6.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libblkmaker/libblkmaker-0.6.0-r2.ebuild')
-rw-r--r--net-libs/libblkmaker/libblkmaker-0.6.0-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-libs/libblkmaker/libblkmaker-0.6.0-r2.ebuild b/net-libs/libblkmaker/libblkmaker-0.6.0-r2.ebuild
new file mode 100644
index 000000000000..b5558db1cedf
--- /dev/null
+++ b/net-libs/libblkmaker/libblkmaker-0.6.0-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="C implementation of Bitcoin's getblocktemplate interface"
+HOMEPAGE="https://github.com/bitcoin/libblkmaker"
+SRC_URI="https://github.com/bitcoin/${PN}/archive/v${PV}.tar.gz -> ${P}-github.tgz"
+
+LICENSE="MIT"
+SLOT="0/7"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/jansson-2.0.0:=
+ dev-libs/libbase58
+"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/libgcrypt )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}