summaryrefslogtreecommitdiff
path: root/net-libs/ldns
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/ldns')
-rw-r--r--net-libs/ldns/Manifest2
-rw-r--r--net-libs/ldns/ldns-1.7.1-r5.ebuild (renamed from net-libs/ldns/ldns-1.7.1-r3.ebuild)18
2 files changed, 11 insertions, 9 deletions
diff --git a/net-libs/ldns/Manifest b/net-libs/ldns/Manifest
index ddbeb73771a7..787481d2fd41 100644
--- a/net-libs/ldns/Manifest
+++ b/net-libs/ldns/Manifest
@@ -1,5 +1,5 @@
AUX ldns-1.7.1-Makefile.patch 1020 BLAKE2B f49a397df95bfcc0ee2eba4cb3f7aa9202d8b940c04a7097c447356198b04f464f10ed5db98db99f4a34ce04ff6d450282306b855a97b72fdc3bbca24f1c0689 SHA512 3779f61e3f20d593843c5b429b7366b826380fe2fb17b74d76d85432189712e34323dad3a653bb45333740caf01d997025b72a96a58ec75cc2fae8c249108e9d
DIST ldns-1.7.1.tar.gz 1244394 BLAKE2B 8f2d9c6e34c4f13924ce1531a5757c4a619fc31ebc5a0a3d4aaf43fcfc8b53e8f371984b1c60ab74f735a05a9ca0710fc29a40fffeaef66eb54395eb3a727a0d SHA512 e8f72a4ff4aa544acac5e7be9a8ba38c6b8d388bb26f9a0ed04c1a921622f8582cc8539beafc76a29187a55c94069b7c1875e77522e1a7e7bb3e297dd1e4c2b7
-EBUILD ldns-1.7.1-r3.ebuild 2617 BLAKE2B 1f137bfba50eb15e4390d6466c21ff09ac0b75e4a8abf7c0e9865b1ec7b931fa27eda22c19210ea05ec9dc08905541faf4f01f6e06550f95ca29b6d0f51830ec SHA512 29d8a964da4fbeaa0365d68a1ef9f6fa13ff588bde3fc2ca0281d962e9567ca590414f425feae7bfc7091512693852d75f6a7862446b86c1e52e4d3f54f206a1
EBUILD ldns-1.7.1-r4.ebuild 2621 BLAKE2B 0585d412d07d38a2dd1744dbd539894c5a4e3d3391d5933464494420e1302cd7d935e39ae16d05bb12fcd9769cd2d1bd4ee15d2bf8e80132ab5ec95a83cd1b69 SHA512 26f81bb4f48a6c1f9f8ae7bf5fbcafc4fcddc1efbf14d34bfd0138cbb75449408731325bedc7179f093861e05696a518de3a7ad877cbf92c26110d3ed2a523d9
+EBUILD ldns-1.7.1-r5.ebuild 2625 BLAKE2B 3afc6b2be0ef0b376fcd0cefe0b3db936a28d2b7c197948c6550d2ad28feccfa6230c3f6b8b9781c21ec8d8aaf28fc6b3195cfc3af3587b14be230bec80c590f SHA512 2285b38c0e76a7f87084dfcb36a1dc3be698f8f0e7499b6fe83573b930324c0fb590f136ee36b950f7aa3f727ee9f6826a59766f255fdfd12812b0823491eceb
MISC metadata.xml 932 BLAKE2B 263b5d8d54aed15ae710d6f3d60ebe1683699c8aef9fd34fe5865ee5d1aa046ae40be8c1239b2ee3f7df57a8f8f6de57b7b693e2c4d7680fc8cfa269bd3cd832 SHA512 40c5a002f31a00ff586f3af4b1f112760a589aeec5846e5335bf39c6a6b2fd0e248dfcd62c1f4956f81f710db1f9998e0dd7b84acd658252d7006c8100631ae7
diff --git a/net-libs/ldns/ldns-1.7.1-r3.ebuild b/net-libs/ldns/ldns-1.7.1-r5.ebuild
index 4796d3ae7c41..14222d28541c 100644
--- a/net-libs/ldns/ldns-1.7.1-r3.ebuild
+++ b/net-libs/ldns/ldns-1.7.1-r5.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python3_{7,8} )
-inherit epatch multilib-minimal python-single-r1
+EAPI=8
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+inherit multilib-minimal python-single-r1
DESCRIPTION="a library with the aim to simplify DNS programming in C"
HOMEPAGE="http://www.nlnetlabs.nl/projects/ldns/"
@@ -11,11 +11,13 @@ SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/3"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~ppc-macos ~x64-macos ~x64-solaris"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="+dane doc +ecdsa ed25519 ed448 gost python static-libs vim-syntax"
# configure will die if ecdsa is enabled and ssl is not
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
RDEPEND="
python? ( ${PYTHON_DEPS} )
@@ -73,7 +75,7 @@ multilib_src_configure() {
src_prepare() {
default
- epatch "${FILESDIR}/${P}-Makefile.patch"
+ eapply -p0 "${FILESDIR}/${P}-Makefile.patch"
# remove non-existing dependency for target packaging/libldns.pc
sed -i 's,packaging/libldns.pc.in,,' "${S}"/Makefile.in || die 'could not patch Makefile.in'
}
@@ -90,14 +92,14 @@ multilib_src_install() {
default
if multilib_is_native_abi && use doc ; then
- dohtml -r doc/html/.
+ dodoc -r doc/html
fi
}
multilib_src_install_all() {
dodoc Changelog README*
- find "${ED}" -name '*.la' -delete || die
+ find "${D}" -name '*.la' -delete || die
use python && python_optimize
if use vim-syntax ; then