summaryrefslogtreecommitdiff
path: root/net-libs/gsnmp/files
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/gsnmp/files')
-rw-r--r--net-libs/gsnmp/files/gsnmp-0.3.0-g_access.patch10
-rw-r--r--net-libs/gsnmp/files/gsnmp-0.3.0-pkg_config.patch31
-rw-r--r--net-libs/gsnmp/files/gsnmp-0.3.0-underquoting.patch11
3 files changed, 52 insertions, 0 deletions
diff --git a/net-libs/gsnmp/files/gsnmp-0.3.0-g_access.patch b/net-libs/gsnmp/files/gsnmp-0.3.0-g_access.patch
new file mode 100644
index 000000000000..505f7d166a9d
--- /dev/null
+++ b/net-libs/gsnmp/files/gsnmp-0.3.0-g_access.patch
@@ -0,0 +1,10 @@
+--- a/src/transport.c
++++ b/src/transport.c
+@@ -32,6 +32,7 @@
+ #include "transport.h"
+ #include "dispatch.h"
+ #include "pdu.h" /* xxx only needed for debugging flags... */
++#include <glib/gstdio.h> /* g_access() */
+
+
+ static GUdpSocket *udp_ipv4_socket = NULL;
diff --git a/net-libs/gsnmp/files/gsnmp-0.3.0-pkg_config.patch b/net-libs/gsnmp/files/gsnmp-0.3.0-pkg_config.patch
new file mode 100644
index 000000000000..2e837caa820d
--- /dev/null
+++ b/net-libs/gsnmp/files/gsnmp-0.3.0-pkg_config.patch
@@ -0,0 +1,31 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -21,10 +21,18 @@
+
+ AC_PROG_LIBTOOL
+
++PKG_PROG_PKG_CONFIG
++
+ dnl Checks for libraries.
+
+-AM_PATH_GLIB_2_0(2.0.0)
+-AM_PATH_GNET_2_0(2.0.4)
++PKG_CHECK_MODULES(GLIB, glib-2.0 > 2.0.0,[
++ LIBS="$LIBS $GLIB_LIBS"
++ CPPFLAGS="$CPPFLAGS $GLIB_CFLAGS"
++ ], AC_MSG_ERROR[Could not find glib])
++PKG_CHECK_MODULES(GNET, gnet-2.0 > 2.0.4,[
++ LIBS="$LIBS $GNET_LIBS"
++ CPPFLAGS="$CPPFLAGS $GNET_CFLAGS"
++ ], AC_MSG_ERROR[Could not find gnet])
+
+ dnl Checks for header files.
+ dnl AC_HEADER_STDC
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,5 +1,3 @@
+-AM_CPPFLAGS = $(GNET_CFLAGS)
+-
+ lib_LTLIBRARIES = libgsnmp.la
+ libgsnmp_la_SOURCES = ber.c ber.h \
+ pdu.c pdu.h \
diff --git a/net-libs/gsnmp/files/gsnmp-0.3.0-underquoting.patch b/net-libs/gsnmp/files/gsnmp-0.3.0-underquoting.patch
new file mode 100644
index 000000000000..877aeceb0b0e
--- /dev/null
+++ b/net-libs/gsnmp/files/gsnmp-0.3.0-underquoting.patch
@@ -0,0 +1,11 @@
+--- a/gsnmp.m4
++++ b/gsnmp.m4
+@@ -1,7 +1,7 @@
+ dnl AM_PATH_GSNMP()
+ dnl
+
+-AC_DEFUN(AM_PATH_GSNMP,
++AC_DEFUN([AM_PATH_GSNMP],
+ [
+ PKG_CHECK_MODULES(GSNMP, glib-2.0 >= 2.0.1)
+ ])