summaryrefslogtreecommitdiff
path: root/net-libs/gnutls/gnutls-3.5.19-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/gnutls/gnutls-3.5.19-r1.ebuild')
-rw-r--r--net-libs/gnutls/gnutls-3.5.19-r1.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/net-libs/gnutls/gnutls-3.5.19-r1.ebuild b/net-libs/gnutls/gnutls-3.5.19-r1.ebuild
index 1635d976bdf4..9fc06eac7ed6 100644
--- a/net-libs/gnutls/gnutls-3.5.19-r1.ebuild
+++ b/net-libs/gnutls/gnutls-3.5.19-r1.ebuild
@@ -34,11 +34,11 @@ DEPEND="${RDEPEND}
test? (
seccomp? ( sys-libs/libseccomp )
)"
-BDEPEND=">=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
- tools? ( sys-devel/autogen )
- valgrind? ( dev-util/valgrind )
+BDEPEND=">=virtual/pkgconfig-0-r1
doc? ( dev-util/gtk-doc )
nls? ( sys-devel/gettext )
+ tools? ( sys-devel/autogen )
+ valgrind? ( dev-util/valgrind )
test-full? (
app-crypt/dieharder
app-misc/datefudge
@@ -79,10 +79,6 @@ src_prepare() {
multilib_src_configure() {
LINGUAS="${LINGUAS//en/en@boldquot en@quot}"
- # remove magic of library detection
- # bug#438222
- local libconf=($("${S}/configure" --help | grep -- '--without-.*-prefix' | sed -e 's/^ *\([^ ]*\) .*/\1/g'))
-
# TPM needs to be tested before being enabled
libconf+=( --without-tpm )
@@ -117,9 +113,11 @@ multilib_src_configure() {
$(use_with idn) \
$(use_with pkcs11 p11-kit) \
$(use_with zlib) \
+ --disable-rpath \
--with-unbound-root-key-file="${EPREFIX}/etc/dnssec/root-anchors.txt" \
--without-included-libtasn1 \
- "${libconf[@]}"
+ "${libconf[@]}" \
+ $("${S}/configure" --help | grep -- '--without-.*-prefix' | sed -e 's/^ *\([^ ]*\) .*/\1/g')
}
multilib_src_install_all() {