summaryrefslogtreecommitdiff
path: root/net-libs/gloox
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/gloox')
-rw-r--r--net-libs/gloox/Manifest2
-rw-r--r--net-libs/gloox/gloox-1.0.21.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/net-libs/gloox/Manifest b/net-libs/gloox/Manifest
index 3e16a4d508b9..a96c40a43d67 100644
--- a/net-libs/gloox/Manifest
+++ b/net-libs/gloox/Manifest
@@ -1,3 +1,5 @@
+DIST gloox-1.0.21.tar.bz2 716449 BLAKE2B 9728b137b088e3ebd067dd88688474e37ec27108cc87ffe6d2d78b206c3215f36c072e333d04c659e5dc9db43c330bcac7ee7f495208bd8df1bbeb72db1e0792 SHA512 ee2c180e6a6e05955707fdd3e790c4c0e7be46fdf071201abd081b8620e3f664045f000804e1a30bddf8a3324e90f211ce5ee870fd5330ab87979dedfeb45575
DIST gloox-1.0.22.tar.bz2 722653 BLAKE2B e029930ae51053772d4f7bb0cb0933cb260aacc571a6fab6b78c0e12cb7e119938c742afcc0e1af037a97c293f03b423a626c9b01dc9ce974b922c7e9054bcf2 SHA512 89b51dbee338ef8b234d934a5536a2e5d83d8121fa624e933b63bd15017d60f941781a1045884d0d125f50370ed7857cf4131242d39f6703e72c9cf064691416
+EBUILD gloox-1.0.21.ebuild 1134 BLAKE2B 65f284fc562483195e09f8412d88876c602cc6ea25750eda6e32a3abc183e522c8427b1e5e62099aeb2d038f3bb60998f9cf249bfd879aab85c73168c6b64f04 SHA512 4a9d5d47ac2a3ec2ad0e103183b8d64f665100859bfa556c55adc659401141c6d84f84014e77a603858ce5b6cc876663f97494e0b1bde3595a642a9c26824d82
EBUILD gloox-1.0.22.ebuild 1117 BLAKE2B cfe30d6bac3e249c88e6825390c504405eaaea78442359d4297c6a0a3cc4f167dd5c1eae12c6d34856a833b4a83247c16123e740b637dd2e7bc6b6c546c16492 SHA512 37ee7375502d50d168b2f79b4d8656424094741fe11c6c9b8d50ea8512fdd0218516c2644d57bbfe6aef4cfdd2f635539bae2c9add09a3cf0f2a0addb279893e
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/net-libs/gloox/gloox-1.0.21.ebuild b/net-libs/gloox/gloox-1.0.21.ebuild
new file mode 100644
index 000000000000..3598babc2d2b
--- /dev/null
+++ b/net-libs/gloox/gloox-1.0.21.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="${P/_/-}"
+DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
+HOMEPAGE="https://camaya.net/gloox/"
+SRC_URI="https://camaya.net/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0/17"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug gnutls idn libressl ssl static-libs test zlib"
+
+DEPEND="idn? ( net-dns/libidn:= )
+ gnutls? ( net-libs/gnutls )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ )
+ zlib? ( sys-libs/zlib )"
+
+RDEPEND="${DEPEND}"
+
+# GnuTLS checks hang forever
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ # Examples are not installed anyway, so - why should we build them?
+ local myeconfargs=(
+ --without-examples
+ $(usex debug "--enable-debug" '')
+ $(use_enable static-libs static)
+ $(use_with idn libidn)
+ $(use_with gnutls)
+ $(use_with ssl openssl)
+ $(use_with test tests)
+ $(use_with zlib)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+}