summaryrefslogtreecommitdiff
path: root/net-libs/glib-networking
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/glib-networking')
-rw-r--r--net-libs/glib-networking/Manifest2
-rw-r--r--net-libs/glib-networking/glib-networking-2.68.2.ebuild80
2 files changed, 82 insertions, 0 deletions
diff --git a/net-libs/glib-networking/Manifest b/net-libs/glib-networking/Manifest
index 559fae5a78d7..bde1cbdd1404 100644
--- a/net-libs/glib-networking/Manifest
+++ b/net-libs/glib-networking/Manifest
@@ -1,3 +1,5 @@
DIST glib-networking-2.68.1.tar.xz 237876 BLAKE2B 11d982a3d65ae5793a3b6c30cf31737ede5879aa3747416253bacc34d62a1ada944a718223300d63a5b37615492929e63c1c0cad6ef34775ee95e49f6769dc04 SHA512 da38b64e6709c864e1c6a60989d86439e0afb1dbf7b7f60a67f58cf430ae354ef9fe7465e74790b0c2827d2f1c39a250db4372d98fab6ab8d73946a7f51e3b22
+DIST glib-networking-2.68.2.tar.xz 239040 BLAKE2B 2b65a63205d3071d05898ca869ae117c9b9fd548b19d9a1c82869a1eb54b77113f8908cd32108f4ca851cc0975ed34c16df04906b5b3c1f9a9a03574187ba929 SHA512 5c2d485332ff1b5a4d0f257b4e7a371b0bfe899b98ee4157845e5f5d3f10cf6f2df891407396edb6955420064dbaa57a5dc3c62c6392881cff05332db925d32d
EBUILD glib-networking-2.68.1.ebuild 1983 BLAKE2B 57f0697fa0db6c58187cb1dd748c31bd039a8999b7b1abdf330c2405e80bf203cbccc86fde0bd69fcf76499d69265ae2c079c6c43dc238ba5cfaef4014a7b375 SHA512 b1a5877223e456e2518c86d9c14128588a1ce169c30d7b5870b6d9ccb93d5f1f3dd2d06bbb5ee07421c1cfcfda07a22fcdfafc974e85afa4b001b190062e9680
+EBUILD glib-networking-2.68.2.ebuild 1990 BLAKE2B 29807f8e6ff7998f584130127d1da2177897b65ad9d196dd6089daa1ace034be7d99ae4c69a7e787e162232f3ae62b5cb2aea55cdacf777b03929e9190174cf5 SHA512 50a2224242df368dfefa2b3826056e802427d1482a3b4d31d555d6892852ad7fd57fdf6d564c8a21460a4407ae68001badda4db839cc754181ce91cab4275e53
MISC metadata.xml 481 BLAKE2B f777702cce7998cc718ae660ab6bfc0842afdfaa4a81f34cc585c18bd94bbce3f0a41c6d23cb1bfe6bdcb008a64e34dca73b4a2e9f048254a5199c2aa698fc36 SHA512 7e72edca01c8141f913340022b2f3682ddb05e96d4c6bdd8abc361b21822ab9f4c0a129aa059e94e420d73fd7187c5477e3b578f5019dfb6fb2427d04698d050
diff --git a/net-libs/glib-networking/glib-networking-2.68.2.ebuild b/net-libs/glib-networking/glib-networking-2.68.2.ebuild
new file mode 100644
index 000000000000..8365ce18f29d
--- /dev/null
+++ b/net-libs/glib-networking/glib-networking-2.68.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson-multilib xdg
+
+DESCRIPTION="Network-related giomodules for glib"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/glib-networking"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="+gnome +libproxy +ssl test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.67.0:2[${MULTILIB_USEDEP}]
+ libproxy? ( >=net-libs/libproxy-0.4.11-r1:=[${MULTILIB_USEDEP}] )
+ >=net-libs/gnutls-3.7.2:=[${MULTILIB_USEDEP}]
+ ssl? ( app-misc/ca-certificates )
+ gnome? ( gnome-base/gsettings-desktop-schemas )
+"
+DEPEND="${RDEPEND}
+ test? ( net-libs/gnutls[pkcs11] )
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? ( sys-apps/dbus )
+"
+
+src_prepare() {
+ xdg_src_prepare
+
+ if ! use test ; then
+ # Don't build tests unconditionally
+ # This is a hack to avoid needing gnutls[pkcs11] when USE=-test
+ # It may become a real runtime dependency in future
+ # Please check!
+ # bug #777462
+ sed -i "/^subdir('tls\/tests')/d" meson.build || die
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dgnutls=enabled
+ -Dopenssl=disabled
+ $(meson_feature libproxy)
+ $(meson_feature gnome gnome_proxy)
+ -Dinstalled_tests=false
+ -Dstatic_modules=false
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ multilib_pkg_postinst() {
+ gnome2_giomodule_cache_update \
+ || die "Update GIO modules cache failed (for ${ABI})"
+ }
+ multilib_foreach_abi multilib_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+
+ multilib_pkg_postrm() {
+ gnome2_giomodule_cache_update \
+ || die "Update GIO modules cache failed (for ${ABI})"
+ }
+ multilib_foreach_abi multilib_pkg_postrm
+}