summaryrefslogtreecommitdiff
path: root/net-libs/glib-networking
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/glib-networking')
-rw-r--r--net-libs/glib-networking/Manifest5
-rw-r--r--net-libs/glib-networking/glib-networking-2.50.0.ebuild83
-rw-r--r--net-libs/glib-networking/metadata.xml14
3 files changed, 102 insertions, 0 deletions
diff --git a/net-libs/glib-networking/Manifest b/net-libs/glib-networking/Manifest
new file mode 100644
index 000000000000..855719ff9697
--- /dev/null
+++ b/net-libs/glib-networking/Manifest
@@ -0,0 +1,5 @@
+DIST glib-networking-2.50.0.tar.xz 435380 SHA256 3f1a442f3c2a734946983532ce59ed49120319fdb10c938447c373d5e5286bee SHA512 a1e9d28a546f83d461057f088ca2467a32be110f444c8ede1cbfeb20244637d8d5fb5b5b0ee4485feb517beebc3536671442bbfdd3ba01663b52e6da138bd7fe WHIRLPOOL c9d2fa9c36fa9e48991ebf09c5719ccb6e0cb72bcdc5a878ea7d1db71d7edf2614ff6a4c91839860cb3f92aae336fd6033c26d8905c06730369e1256435ee47a
+EBUILD glib-networking-2.50.0.ebuild 2308 SHA256 f5af352a49d39986cafaa1f0f73525b72ff12211ec93e72a644824cf5f04d97d SHA512 1a9517ee0e22d261aec3f6cfbcfa7abe7709968a1960dfddf5c963163873faec0a5ab091e5c940fa0550786fc0dd9be709c79fa9d969a6a1bc2be260590f2569 WHIRLPOOL cf65d6c3c4286e0830231ad455a4168b654f93a93cdef3b87d113d5d32f0af778cc2e5000baf8dd720656b25e814cc865791daccd6e652a66312b432f52b9638
+MISC ChangeLog 7755 SHA256 dec93942dd959d7b4303e5d42416357445c093e43cec2adcfb84ca2343627a00 SHA512 adc610d0c8d1b40406aee8d84efab2a1262db2db6699597938542220f444fd0138e9e443ad2b622044a609b4a66811afe7d0f2280d6cf34fe32e6dd204aad888 WHIRLPOOL d1d21498a694fbcba74deeaa2af4d8dd2959194912906f4ef9acab4013feb4c5b8768d28ef0bd076fbfc5a62884ff1606815784c60e76a99aeb75627ca9c7379
+MISC ChangeLog-2015 15406 SHA256 23918eed03354b6dd370825f0a75ceecf1813990177bdf42ecd91f92545cb066 SHA512 ee073f26740b63eede4e4852e1b3d2e54241503c80d19a7d4e0fce0914926709e8081336dc0f7a4b59d12a201777d0b3ed996e259e8b9ab8ee4ea7ace9704b77 WHIRLPOOL 8362601f27c0939564666260ed5ea49e83b5b35b861d537f27ddb5fe5d1726b1cf6dc17069494fd1a0e093c04379b25f31543cfddcc6e685431114b035994340
+MISC metadata.xml 494 SHA256 86287bb4e2ba4170ac85550225ab37204785978a63f2432eb51e9b50ef7a380c SHA512 40a0f76e5ed695d7700526e1d6d854a50cc00f37e065bf332be51addad6a4be4567c313ca8ce8259fa809ded1f023daeb77f36ff660650d5d525465e952ea048 WHIRLPOOL 49f7381454bec2b224785ef08093c51c69b633e49bca8fbd71992bfbc665e10a412f7d26bd80b5cc3f0b5c2857b4e4e85a3ae53766d20410a9151e03f4806403
diff --git a/net-libs/glib-networking/glib-networking-2.50.0.ebuild b/net-libs/glib-networking/glib-networking-2.50.0.ebuild
new file mode 100644
index 000000000000..37abdfa1ecf6
--- /dev/null
+++ b/net-libs/glib-networking/glib-networking-2.50.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 multilib-minimal virtualx
+
+DESCRIPTION="Network-related giomodules for glib"
+HOMEPAGE="https://git.gnome.org/browse/glib-networking/"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+IUSE="+gnome +libproxy smartcard +ssl test"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.46.0:2[${MULTILIB_USEDEP}]
+ gnome? ( gnome-base/gsettings-desktop-schemas )
+ libproxy? ( >=net-libs/libproxy-0.4.11-r1:=[${MULTILIB_USEDEP}] )
+ smartcard? (
+ >=app-crypt/p11-kit-0.18.4[${MULTILIB_USEDEP}]
+ >=net-libs/gnutls-3:=[pkcs11,${MULTILIB_USEDEP}] )
+ ssl? (
+ app-misc/ca-certificates
+ >=net-libs/gnutls-3:=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.19.4
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ test? ( sys-apps/dbus[X] )
+"
+# eautoreconf needs >=sys-devel/autoconf-2.65:2.5
+
+src_prepare() {
+ default
+ # Disable SSLv3 requiring fallback test, which fails with net-libs/gnutls[-sslv3], bug 595952
+ # https://bugzilla.gnome.org/show_bug.cgi?id=782853
+ sed -i -e '/\/tls\/connection\/fallback\/SSL/d' "${S}"/tls/tests/connection.c || die
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ --disable-static \
+ --with-ca-certificates="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt \
+ $(use_with gnome gnome-proxy) \
+ $(use_with libproxy) \
+ $(use_with smartcard pkcs11) \
+ $(use_with ssl gnutls)
+}
+
+multilib_src_test() {
+ # XXX: non-native tests fail if glib-networking is already installed.
+ # have no idea what's wrong. would appreciate some help.
+ multilib_is_native_abi || return 0
+
+ virtx emake check
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ multilib_pkg_postinst() {
+ gnome2_giomodule_cache_update \
+ || die "Update GIO modules cache failed (for ${ABI})"
+ }
+ multilib_foreach_abi multilib_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+
+ multilib_pkg_postrm() {
+ gnome2_giomodule_cache_update \
+ || die "Update GIO modules cache failed (for ${ABI})"
+ }
+ multilib_foreach_abi multilib_pkg_postrm
+}
diff --git a/net-libs/glib-networking/metadata.xml b/net-libs/glib-networking/metadata.xml
new file mode 100644
index 000000000000..c28b1613d4c5
--- /dev/null
+++ b/net-libs/glib-networking/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <use>
+ <flag name="libproxy">Use <pkg>net-libs/libproxy</pkg> for getting
+ the HTTP/HTTPS/SOCKS proxy configuration</flag>
+ <flag name="gnome">Extract HTTP/HTTPS/SOCKS proxy configuration
+ stored using GSettings</flag>
+ </use>
+</pkgmetadata>