summaryrefslogtreecommitdiff
path: root/net-libs/farstream
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/farstream')
-rw-r--r--net-libs/farstream/Manifest3
-rw-r--r--net-libs/farstream/farstream-0.2.8-r2.ebuild6
-rw-r--r--net-libs/farstream/files/farstream-0.2.8-make43.patch60
3 files changed, 67 insertions, 2 deletions
diff --git a/net-libs/farstream/Manifest b/net-libs/farstream/Manifest
index 77cce07e92b7..11e1c6555ab9 100644
--- a/net-libs/farstream/Manifest
+++ b/net-libs/farstream/Manifest
@@ -1,3 +1,4 @@
+AUX farstream-0.2.8-make43.patch 1959 BLAKE2B d7c18eaf156a6cca991014dc512898cf93f1b67b10c78f28bf6cebf772d4a8974daba1305f06d7087f43fd766218d49724dca471835fcfe5dff06a105f40bb53 SHA512 c577c5f9fb384f93ce7e36cff117d3c2dea92dc7b15064dfed19d18fc5d8658044df19e2f0cc112cd347e35c6038501e0b05a1f97c95b0f43f776aabd8fba01b
DIST farstream-0.2.8.tar.gz 1315548 BLAKE2B 3f90e6150fd13d02369837b019ad3b935165130b8396133697d0819861f5a5ed79c6eab3efdc3bcc5a6887807285bece21f188bc756ec3cd64a57f5682f5b348 SHA512 7ec5c57f8778f4107cb628dbf411e38b726152cf78920127dff4423239ff7e4980b6b4f938abba2aa21ab984b1e3053e7e648611322a0ce94df0af576df99a7e
-EBUILD farstream-0.2.8-r2.ebuild 1860 BLAKE2B e80d8868614111ba86fa4d803d74451b942208b299acd0a282f9437f3abb097f51e749787798273512b182b11dba538071bd178a8e606a4fe1e9081a9f8fdd0a SHA512 91fafd03bc9be4a0b886649f8cfa66dcddf811b782855d3ca159f47daaad97733935bdda530b1db3d2d90954476dafc4d9f4417500148c226b96d32d5a0bbb80
+EBUILD farstream-0.2.8-r2.ebuild 1953 BLAKE2B e9c9f5de6b43a6247c4baccce3efb5479800fa644c00101006f23f736a9da3bf6d3094bd19d884ba7080eba6282cc188738316926e892bec56d105005b229433 SHA512 12809e87540775ebfcafff08e2ba0a87f068cb17bf03f013886c3db8a13d38412c7a5e944f168aa11baf045ef81b55dd2abba7da635346886c7f2a5c49804882
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/net-libs/farstream/farstream-0.2.8-r2.ebuild b/net-libs/farstream/farstream-0.2.8-r2.ebuild
index c5a2f6eb67f3..6f6083115146 100644
--- a/net-libs/farstream/farstream-0.2.8-r2.ebuild
+++ b/net-libs/farstream/farstream-0.2.8-r2.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="https://www.freedesktop.org/wiki/Software/Farstream"
SRC_URI="https://freedesktop.org/software/farstream/releases/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1+"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
IUSE="+introspection test upnp"
SLOT="0.2/5" # .so version
@@ -44,6 +44,10 @@ DEPEND="${COMMONDEPEND}
media-libs/gst-plugins-good:1.0 )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.8-make43.patch # remove when bumping and switching to Meson
+)
+
pkg_setup() {
python-any-r1_pkg_setup
}
diff --git a/net-libs/farstream/files/farstream-0.2.8-make43.patch b/net-libs/farstream/files/farstream-0.2.8-make43.patch
new file mode 100644
index 000000000000..c1e1c0d42791
--- /dev/null
+++ b/net-libs/farstream/files/farstream-0.2.8-make43.patch
@@ -0,0 +1,60 @@
+--- a/farstream/Makefile.in
++++ b/farstream/Makefile.in
+@@ -17,6 +17,8 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
+
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_gen_prefix=gst_color_balance
+@@ -549,7 +551,7 @@
+ glib_enum_define = FS
+ glib_gen_prefix = _fs
+ glib_gen_basename = fs
+-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers = $(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
+ @HAVE_INTROSPECTION_TRUE@introspection_sources = \
+ @HAVE_INTROSPECTION_TRUE@ $(libfarstream_@FS_APIVERSION@_la_SOURCES) \
+ @HAVE_INTROSPECTION_TRUE@ $(nodist_libfarstreaminclude_HEADERS) \
+--- a/gst/fsrtpconference/Makefile.in
++++ b/gst/fsrtpconference/Makefile.in
+@@ -17,6 +17,8 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
+
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_gen_prefix=gst_color_balance
+@@ -569,7 +571,7 @@
+ glib_enum_define = FS_RTP
+ glib_gen_prefix = _fs_rtp
+ glib_gen_basename = fs-rtp
+-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers = $(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
+ all: all-am
+
+ .SUFFIXES:
+--- a/transmitters/rawudp/Makefile.in
++++ b/transmitters/rawudp/Makefile.in
+@@ -17,6 +17,8 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
+
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_gen_prefix=gst_color_balance
+@@ -496,7 +498,7 @@
+ glib_enum_define = FS_RAWUDP
+ glib_gen_prefix = _fs_rawudp
+ glib_gen_basename = fs-rawudp
+-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers = $(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
+ all: all-am
+
+ .SUFFIXES: