summaryrefslogtreecommitdiff
path: root/net-libs/cppzmq/cppzmq-4.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/cppzmq/cppzmq-4.6.0.ebuild')
-rw-r--r--net-libs/cppzmq/cppzmq-4.6.0.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/net-libs/cppzmq/cppzmq-4.6.0.ebuild b/net-libs/cppzmq/cppzmq-4.6.0.ebuild
deleted file mode 100644
index 48351df3d3b6..000000000000
--- a/net-libs/cppzmq/cppzmq-4.6.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="High-level CPP Binding for ZeroMQ"
-HOMEPAGE="https://github.com/zeromq/cppzmq"
-SRC_URI="https://github.com/zeromq/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86 ~x86-linux"
-
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=net-libs/zeromq-4.3.1"
-# Tests require cmake modules from catch2 and headers from older version of catch
-DEPEND="${RDEPEND}
- test? ( >=dev-cpp/catch-2.5.0
- <dev-cpp/catch-2
- )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-disable-static.patch"
- "${FILESDIR}/${PN}-use-system-catch2.patch"
-)
-
-src_configure() {
- local mycmakeargs=(
- -DCPPZMQ_CMAKECONFIG_INSTALL_DIR="/usr/$(get_libdir)/cmake/${PN}/"
- -DCPPZMQ_BUILD_TESTS="$(usex test)"
- )
- if has_version -d '>=net-libs/zeromq-4.3.1[drafts]'; then
- mycmakeargs+=( -DENABLE_DRAFTS=on )
- fi
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
- einstalldocs
-}