summaryrefslogtreecommitdiff
path: root/net-irc/znc/znc-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/znc/znc-9999.ebuild')
-rw-r--r--net-irc/znc/znc-9999.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/net-irc/znc/znc-9999.ebuild b/net-irc/znc/znc-9999.ebuild
index c40af00c86f0..4245192ac954 100644
--- a/net-irc/znc/znc-9999.ebuild
+++ b/net-irc/znc/znc-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{10..12} )
inherit cmake python-single-r1 readme.gentoo-r1 systemd
-GTEST_VER="1.8.1"
+GTEST_VER="1.14.0"
GTEST_URL="https://github.com/google/googletest/archive/${GTEST_VER}.tar.gz -> gtest-${GTEST_VER}.tar.gz"
DESCRIPTION="An advanced IRC Bouncer"
@@ -21,7 +21,7 @@ else
https://znc.in/releases/archive/${MY_P}.tar.gz
test? ( ${GTEST_URL} )
"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+ KEYWORDS="~amd64"
S=${WORKDIR}/${MY_P}
fi
@@ -30,7 +30,7 @@ LICENSE="Apache-2.0"
# "If you upgrade your ZNC version, you must recompile all your modules."
# - https://wiki.znc.in/Compiling_modules
SLOT="0/${PV}"
-IUSE="+icu nls perl python +ssl sasl tcl test +zlib"
+IUSE="+argon2 +icu nls perl python +ssl sasl tcl test +zlib"
RESTRICT="!test? ( test )"
# tests run znc-buildmod which is a Python script
@@ -57,7 +57,8 @@ BDEPEND="
)
"
DEPEND="
- app-crypt/argon2:=
+ dev-cpp/cctz:=
+ argon2? ( app-crypt/argon2:= )
icu? ( dev-libs/icu:= )
nls? ( dev-libs/boost:=[nls] )
perl? ( >=dev-lang/perl-5.10:= )
@@ -74,7 +75,7 @@ RDEPEND="
"
PATCHES=(
- "${FILESDIR}"/${PN}-1.7.1-inttest-dir.patch
+ "${FILESDIR}/${PN}-1.7.1-inttest-dir.patch"
)
pkg_setup() {
@@ -103,6 +104,7 @@ src_configure() {
-DWANT_SYSTEMD=yes # Causes -DSYSTEMD_DIR to be used.
-DSYSTEMD_DIR="$(systemd_get_systemunitdir)"
-DWANT_ICU="$(usex icu)"
+ -DWANT_ARGON="$(usex argon2)"
-DWANT_IPV6=yes
-DWANT_I18N="$(usex nls)"
-DWANT_PERL="$(usex perl)"
@@ -115,8 +117,8 @@ src_configure() {
)
if [[ ${PV} != *9999* ]] && use test; then
- export GTEST_ROOT="${WORKDIR}/googletest-release-${GTEST_VER}/googletest"
- export GMOCK_ROOT="${WORKDIR}/googletest-release-${GTEST_VER}/googlemock"
+ export GTEST_ROOT="${WORKDIR}/googletest-${GTEST_VER}/googletest"
+ export GMOCK_ROOT="${WORKDIR}/googletest-${GTEST_VER}/googlemock"
fi
cmake_src_configure