summaryrefslogtreecommitdiff
path: root/net-irc/weechat/weechat-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/weechat/weechat-9999.ebuild')
-rw-r--r--net-irc/weechat/weechat-9999.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-irc/weechat/weechat-9999.ebuild b/net-irc/weechat/weechat-9999.ebuild
index f1a4b884780e..e06ceeeda127 100644
--- a/net-irc/weechat/weechat-9999.ebuild
+++ b/net-irc/weechat/weechat-9999.ebuild
@@ -29,7 +29,8 @@ SLOT="0/${PV}"
NETWORKS="+irc"
PLUGINS="+alias +buflist +charset +exec +fifo +fset +logger +relay +scripts +spell +trigger +typing +xfer"
# dev-lang/v8 was dropped from Gentoo so we can't enable javascript support
-SCRIPT_LANGS="guile lua +perl php +python ruby tcl"
+# dev-lang/php eclass support is lacking, php plugins don't work. bug #705702
+SCRIPT_LANGS="guile lua +perl +python ruby tcl"
LANGS=" cs de es fr it ja pl ru"
IUSE="doc man nls selinux test ${SCRIPT_LANGS} ${PLUGINS} ${INTERFACES} ${NETWORKS}"
@@ -51,7 +52,6 @@ RDEPEND="
lua? ( ${LUA_DEPS} )
nls? ( virtual/libintl )
perl? ( dev-lang/perl:= )
- php? ( >=dev-lang/php-7.0:*[embed] )
python? ( ${PYTHON_DEPS} )
ruby? (
|| (
@@ -132,6 +132,7 @@ src_configure() {
-DENABLE_JAVASCRIPT=OFF
-DENABLE_LARGEFILE=ON
-DENABLE_NCURSES=ON
+ -DENABLE_PHP=OFF
-DENABLE_ALIAS=$(usex alias)
-DENABLE_BUFLIST=$(usex buflist)
-DENABLE_CHARSET=$(usex charset)
@@ -146,7 +147,6 @@ src_configure() {
-DENABLE_MAN=$(usex man)
-DENABLE_NLS=$(usex nls)
-DENABLE_PERL=$(usex perl)
- -DENABLE_PHP=$(usex php)
-DENABLE_PYTHON=$(usex python)
-DENABLE_RELAY=$(usex relay)
-DENABLE_RUBY=$(usex ruby)