summaryrefslogtreecommitdiff
path: root/net-irc/ii/ii-1.7-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/ii/ii-1.7-r1.ebuild')
-rw-r--r--net-irc/ii/ii-1.7-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-irc/ii/ii-1.7-r1.ebuild b/net-irc/ii/ii-1.7-r1.ebuild
new file mode 100644
index 000000000000..4a1fce5af761
--- /dev/null
+++ b/net-irc/ii/ii-1.7-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit fixheadtails toolchain-funcs
+
+DESCRIPTION="A minimalist FIFO and filesystem-based IRC client"
+HOMEPAGE="https://tools.suckless.org/ii/"
+SRC_URI="https://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/^CFLAGS/{s: -Os::g; s:= :+= :g}' \
+ -e '/^CC/d' \
+ -e '/^LDFLAGS/{s:-s::g; s:= :+= :g}' \
+ config.mk || die
+ sed -i \
+ -e 's|@${CC}|$(CC)|g' \
+ Makefile || die
+
+ ht_fix_file query.sh
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ii
+ newbin query.sh ii-query
+ dodoc CHANGES FAQ README
+ doman *.1
+}