summaryrefslogtreecommitdiff
path: root/net-irc/hexchat/hexchat-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/hexchat/hexchat-9999.ebuild')
-rw-r--r--net-irc/hexchat/hexchat-9999.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/net-irc/hexchat/hexchat-9999.ebuild b/net-irc/hexchat/hexchat-9999.ebuild
index 0184ad5a0be2..06de44ed5d3d 100644
--- a/net-irc/hexchat/hexchat-9999.ebuild
+++ b/net-irc/hexchat/hexchat-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
LUA_COMPAT=( lua5-{1..4} luajit )
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit lua-single meson mono-env python-single-r1 xdg
@@ -13,17 +13,19 @@ HOMEPAGE="https://hexchat.github.io/"
if [[ "${PV}" == "9999" ]] ; then
inherit git-r3
+ # We need to empty SRC_URI or else mono-env breaks the live ebuild
SRC_URI=""
EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
else
SRC_URI="https://dl.hexchat.net/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
fi
LICENSE="GPL-2 plugin-fishlim? ( MIT )"
SLOT="0"
IUSE="dbus debug +gtk libcanberra lua perl plugin-checksum plugin-fishlim plugin-sysinfo python ssl theme-manager"
REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
+ plugin-fishlim? ( ssl )
python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
@@ -46,7 +48,10 @@ RDEPEND="
ssl? ( dev-libs/openssl:0= )
theme-manager? (
|| (
- ( dev-lang/mono[minimal] dev-dotnet/libgdiplus )
+ (
+ dev-lang/mono[minimal]
+ dev-dotnet/libgdiplus
+ )
dev-lang/mono[-minimal]
)
)"