summaryrefslogtreecommitdiff
path: root/net-irc/hexchat/hexchat-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/hexchat/hexchat-9999.ebuild')
-rw-r--r--net-irc/hexchat/hexchat-9999.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/net-irc/hexchat/hexchat-9999.ebuild b/net-irc/hexchat/hexchat-9999.ebuild
index 0a64b4be026b..850dd84f2ac3 100644
--- a/net-irc/hexchat/hexchat-9999.ebuild
+++ b/net-irc/hexchat/hexchat-9999.ebuild
@@ -3,9 +3,10 @@
EAPI=7
+LUA_COMPAT=( lua5-{1..4} luajit )
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit meson mono-env python-single-r1 xdg
+inherit lua-single meson mono-env python-single-r1 xdg
DESCRIPTION="Graphical IRC client based on XChat"
HOMEPAGE="https://hexchat.github.io/"
@@ -16,13 +17,14 @@ if [[ "${PV}" == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
else
SRC_URI="https://dl.hexchat.net/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
fi
LICENSE="GPL-2 plugin-fishlim? ( MIT )"
SLOT="0"
IUSE="dbus debug +gtk libcanberra libnotify libproxy libressl lua perl plugin-checksum plugin-fishlim plugin-sysinfo python ssl theme-manager"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
dev-libs/glib:2
@@ -36,7 +38,7 @@ RDEPEND="
libcanberra? ( media-libs/libcanberra )
libproxy? ( net-libs/libproxy )
libnotify? ( x11-libs/libnotify )
- lua? ( dev-lang/lua:0= )
+ lua? ( ${LUA_DEPS} )
perl? ( dev-lang/perl:= )
plugin-sysinfo? ( sys-apps/pciutils )
python? ( ${PYTHON_DEPS} )
@@ -61,6 +63,7 @@ BDEPEND="
"
pkg_setup() {
+ use lua && lua-single_pkg_setup
use python && python-single-r1_pkg_setup
if use theme-manager ; then
mono-env_pkg_setup
@@ -82,7 +85,7 @@ src_configure() {
-Ddbus-service-use-appid=false
-Dwith-checksum="$(usex plugin-checksum true false)"
-Dwith-fishlim="$(usex plugin-fishlim true false)"
- -Dwith-lua="$(usex lua lua false)"
+ -Dwith-lua="$(usex lua ${ELUA} false)"
-Dwith-perl="$(usex perl "${EPREFIX}"/usr/bin/perl false)"
-Dwith-python="$(usex python "${EPYTHON/.*}" false)"
-Dwith-sysinfo="$(usex plugin-sysinfo true false)"