summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Manifest.gzbin9909 -> 9751 bytes
-rw-r--r--net-im/ekg2/Manifest4
-rw-r--r--net-im/ekg2/ekg2-0.4_pre20190315-r1.ebuild107
-rw-r--r--net-im/ekg2/ekg2-9999.ebuild104
-rw-r--r--net-im/ekg2/metadata.xml19
-rw-r--r--net-im/skypeforlinux/Manifest2
-rw-r--r--net-im/skypeforlinux/skypeforlinux-8.96.0.207.ebuild100
7 files changed, 102 insertions, 234 deletions
diff --git a/net-im/Manifest.gz b/net-im/Manifest.gz
index f6a4ff5d2075..a9fe2a7ec76f 100644
--- a/net-im/Manifest.gz
+++ b/net-im/Manifest.gz
Binary files differ
diff --git a/net-im/ekg2/Manifest b/net-im/ekg2/Manifest
deleted file mode 100644
index 75512c66f704..000000000000
--- a/net-im/ekg2/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-DIST ekg2-f427d083ee899d42532c046100490a915b0e8a82.tar.gz 1177484 BLAKE2B 7bf6918a7f75738ac34eeae64ac53d3c90acd72795711c856206b79ca96c94b2ce397132ee31dfa8a9060d91d7b4b9aa23834596fca190dadf476660c6e5cd71 SHA512 ba28b66233290bd6c9b6a9602a5409c0fb2d847993bda638172da2f68430b5b5cf9bc0ff0d327983939fa0fd078bf6030069c60cd8bdd8449c349964b23e1f44
-EBUILD ekg2-0.4_pre20190315-r1.ebuild 2561 BLAKE2B 3019822a4e39c66366cd0337fc18a7588a9c20585aab2e5bf14da91213e222168d86896f4e07262b5c729161e9653af0d4d6be20aae65c6b3ba9dce6a208c199 SHA512 f9626e56edae4ec6ff201348dd7b64665b35a2f15615337675669ac45694fea62296dd13dca1cebd3f77a63d99e850728eb853524eb44838bca7091b2aac45e8
-EBUILD ekg2-9999.ebuild 2422 BLAKE2B 3ea811a69c7705ce46920602f7a7a2acf4890205603fd0d280ab4d6be917cba67e57b54e62479aa2ccd9dfbe48115eed38b2cbc523f3ac40f79f8f494262ba78 SHA512 e7dd6624c848463c60edd852c4344fbcff16159b0676a66e4258077ea41e9bd2f9c24f340c94619bf64053f1ad7d2d85ad51ab557c0d0be649e44c017ac1ff9c
-MISC metadata.xml 711 BLAKE2B 3772d8931d48ab7aef557b47c4a5cb420b483c7920343abc3f687dd0de5359a0ab13a465e75f6ca47775d0867c8c8a09a4cb0672f2fbc89c1bdd9f9494122a44 SHA512 502fb9077cd6e265915cb134b3a963408220ea7f2f838b81d4dd2d4162c88770c9af3816008c005ad40758f27f5f11daeb97cc38bdea234a0686cc034436fa4d
diff --git a/net-im/ekg2/ekg2-0.4_pre20190315-r1.ebuild b/net-im/ekg2/ekg2-0.4_pre20190315-r1.ebuild
deleted file mode 100644
index 3dfe36b6ea6c..000000000000
--- a/net-im/ekg2/ekg2-0.4_pre20190315-r1.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools
-
-EGIT_COMMIT="f427d083ee899d42532c046100490a915b0e8a82"
-DESCRIPTION="Text-based, multi-protocol instant messenger"
-HOMEPAGE="https://github.com/ekg2/ekg2/"
-SRC_URI="https://github.com/ekg2/ekg2/archive/${EGIT_COMMIT}.tar.gz
- -> ${PN}-${EGIT_COMMIT}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="gadu gpm gpg gtk minimal ncurses nls nntp openssl
- perl readline rss spell sqlite ssl xmpp unicode zlib"
-
-RDEPEND="dev-libs/glib:2
- gadu? ( <net-libs/libgadu-1.12:0= )
- gpg? ( app-crypt/gpgme:= )
- gtk? ( x11-libs/gtk+:2 )
- nls? ( virtual/libintl:0= )
- openssl? ( dev-libs/openssl:0= )
- perl? ( dev-lang/perl:0= )
- readline? ( sys-libs/readline:0= )
- rss? ( dev-libs/expat:0= )
- ssl? ( net-libs/gnutls:0= )
- xmpp? ( dev-libs/expat:0= )
- zlib? ( sys-libs/zlib:0= )
-
- ncurses? ( sys-libs/ncurses:=[unicode(+)=]
- gpm? ( sys-libs/gpm:0= )
- spell? ( app-text/aspell:0= ) )
- sqlite? ( dev-db/sqlite:3= )"
-
-DEPEND="${RDEPEND}
- sys-devel/gettext"
-
-S=${WORKDIR}/${PN}-${EGIT_COMMIT}
-
-DOCS=(
- AUTHORS README.md docs/README docs/TODO
- docs/events.txt docs/mouse.txt docs/sim.txt docs/voip.txt
- docs/themes.txt docs/themes-en.txt
- docs/ui-ncurses.txt docs/ui-ncurses-en.txt
-)
-
-pkg_pretend() {
- if ! use gtk && ! use ncurses && ! use readline; then
- ewarn 'ekg2 is being compiled without any frontend. You should consider'
- ewarn 'enabling at least one of following USEflags:'
- ewarn ' gtk, ncurses, readline.'
- fi
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myconf=(
- # direct plugin references
- $(use_enable gadu gg)
- $(use_enable gpg)
- $(use_enable gtk)
- $(use_enable ncurses)
- $(use_enable nntp)
- $(use_enable openssl sim)
- $(use_enable perl)
- --disable-python
- $(use_enable readline)
- $(use_enable rss)
- $(use_enable sqlite logsqlite)
- $(use_enable xmpp jabber)
-
- $(use_enable !minimal autoresponder)
- $(use_enable !minimal jogger)
- $(use_enable !minimal mail)
- $(use_enable !minimal polchat)
- $(use_enable !minimal rivchat)
- $(use_enable !minimal sms)
-
- # sqlite switch
- --with-sqlite3
-
- # optional deps
- $(use_with gpm)
- # do not pass --with-inotify as it will fail if check fails
- $(use_with spell aspell)
- $(use_with ssl gnutls)
- $(use_with zlib)
-
- # other magic
- $(use_enable nls)
- --with-perl-module-build-flags='INSTALLDIRS=vendor'
- --enable-fast-configure
- )
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -delete || die
-}
diff --git a/net-im/ekg2/ekg2-9999.ebuild b/net-im/ekg2/ekg2-9999.ebuild
deleted file mode 100644
index 3243fa4af2fd..000000000000
--- a/net-im/ekg2/ekg2-9999.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools git-r3
-
-DESCRIPTION="Text-based, multi-protocol instant messenger"
-HOMEPAGE="https://github.com/ekg2/ekg2/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/ekg2/${PN}.git"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE="gadu gpm gpg gtk minimal ncurses nls nntp openssl
- perl readline rss spell sqlite ssl xmpp unicode zlib"
-
-RDEPEND="dev-libs/glib:2
- gadu? ( <net-libs/libgadu-1.12:0= )
- gpg? ( app-crypt/gpgme:= )
- gtk? ( x11-libs/gtk+:2 )
- nls? ( virtual/libintl:0= )
- openssl? ( dev-libs/openssl:0= )
- perl? ( dev-lang/perl:0= )
- readline? ( sys-libs/readline:0= )
- rss? ( dev-libs/expat:0= )
- ssl? ( net-libs/gnutls:0= )
- xmpp? ( dev-libs/expat:0= )
- zlib? ( sys-libs/zlib:0= )
-
- ncurses? ( sys-libs/ncurses:=[unicode(+)=]
- gpm? ( sys-libs/gpm:0= )
- spell? ( app-text/aspell:0= ) )
- sqlite? ( dev-db/sqlite:3= )"
-
-DEPEND="${RDEPEND}
- sys-devel/gettext"
-
-DOCS=(
- AUTHORS README.md docs/README docs/TODO
- docs/events.txt docs/mouse.txt docs/sim.txt docs/voip.txt
- docs/themes.txt docs/themes-en.txt
- docs/ui-ncurses.txt docs/ui-ncurses-en.txt
-)
-
-pkg_pretend() {
- if ! use gtk && ! use ncurses && ! use readline; then
- ewarn 'ekg2 is being compiled without any frontend. You should consider'
- ewarn 'enabling at least one of following USEflags:'
- ewarn ' gtk, ncurses, readline.'
- fi
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myconf=(
- # direct plugin references
- $(use_enable gadu gg)
- $(use_enable gpg)
- $(use_enable gtk)
- $(use_enable ncurses)
- $(use_enable nntp)
- $(use_enable openssl sim)
- $(use_enable perl)
- --disable-python
- $(use_enable readline)
- $(use_enable rss)
- $(use_enable sqlite logsqlite)
- $(use_enable xmpp jabber)
-
- $(use_enable !minimal autoresponder)
- $(use_enable !minimal jogger)
- $(use_enable !minimal mail)
- $(use_enable !minimal polchat)
- $(use_enable !minimal rivchat)
- $(use_enable !minimal sms)
-
- # sqlite switch
- --with-sqlite3
-
- # optional deps
- $(use_with gpm)
- # do not pass --with-inotify as it will fail if check fails
- $(use_with spell aspell)
- $(use_with ssl gnutls)
- $(use_with zlib)
-
- # other magic
- $(use_enable nls)
- --with-perl-module-build-flags='INSTALLDIRS=vendor'
- --enable-fast-configure
- )
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -delete || die
-}
diff --git a/net-im/ekg2/metadata.xml b/net-im/ekg2/metadata.xml
deleted file mode 100644
index 254271117728..000000000000
--- a/net-im/ekg2/metadata.xml
+++ /dev/null
@@ -1,19 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>mgorny@gentoo.org</email>
- <name>Michał Górny</name>
- </maintainer>
-
- <use>
- <flag name="gadu">Enable Gadu-Gadu protocol support (requires
- <pkg>net-libs/libgadu</pkg>).</flag>
- <flag name="gpg">Enable jabber message encryption through
- <pkg>app-crypt/gpgme</pkg>.</flag>
- <flag name="minimal">Disable building extra plugins with no additional
- deps.</flag>
- <flag name="openssl">Support encryption in sim plugin, using OpenSSL.</flag>
- <flag name="sqlite">Support logging messages into SQLite3 database.</flag>
- </use>
-</pkgmetadata>
diff --git a/net-im/skypeforlinux/Manifest b/net-im/skypeforlinux/Manifest
index c674d1da0f23..d5f914e5ae93 100644
--- a/net-im/skypeforlinux/Manifest
+++ b/net-im/skypeforlinux/Manifest
@@ -1,7 +1,9 @@
DIST skypeforlinux_8.94.0.422-1.x86_64.rpm 126401643 BLAKE2B 16f5ef2adaf8f3fe9bbe2358ceaf60185da41f221ce9eb61fdb007d1ec07fb8adbca37a88a4a6399b9a30f98fdce26af9174f34a4e1589243d9e4120f0817d21 SHA512 4a1b8869e3c710e2895dcf832654e83379b7ef28ae3ee6e42cc739549cc9108845df71c4e9282f10d764bd3c280c45fae3859ebd3b38f29039f6230aacb0c462
DIST skypeforlinux_8.94.0.428-1.x86_64.rpm 126374668 BLAKE2B e90c5207c1ec0d2835158fd9a7382d8c412ab4f880200b4570195d1453f81b6a5aea26edb49eac153dd680a270fd8ef4f43b4c7a4bf1abd802f2cacef18256c3 SHA512 6623384ee97274cca43fa1013eeab14508e47b4b649b4b633025f658116147c3a4cce9eb584ed6b4f51e5dcb7e323b61c01c7fbd2bdd7a33224131941bb8a727
DIST skypeforlinux_8.95.0.408-1.x86_64.rpm 126523292 BLAKE2B 5e6018b7a2aef8a8cf4311cb50475af7f7799e93d2a1e8b4755428b0ce670819db9c106ac830121b75543c03fed7fc08c910544eb7d3dfb57c11fd7f30df9319 SHA512 c4acdb94e962753e61386e0c0ff18e217a395d5f919ed70ef83e655ca5bd7758f53391dbe977f0b0ffc27c5ea7ec465bf168fec557de3040db425cc365e8eff7
+DIST skypeforlinux_8.96.0.207-1.x86_64.rpm 124580688 BLAKE2B 8bd2dfecee6730d4aeb49bef0e08fd1fd17aecf31a8cd81b5d0ba3d4a8bc6808bd6e08d7c91d39aa46982502b23c8e37c5f4ce2ae87da963cc0df8a8b8ed430d SHA512 27406615892a12a390d47e2a2087149c29a195e942d9fb1748ad1f7cb39012fdad0836b01c4bfe6e690e1a27f67ccdd6d0da2f4baa3cf6567733d95b5a35be17
EBUILD skypeforlinux-8.94.0.422.ebuild 3250 BLAKE2B 760f4a7ffe0493541d0b941ee83cf0ce99150ee90aadcbe4ad2f244fad2b0df5218e240500428f4da3d40ca7a586e135878083d2c4173fd00009f50fa91641b7 SHA512 cdacf86cd0534a1f2d204dbeaf689f2e62903308561fe68b88d981f5c985eaa16d1057226e786e243c87d48619a77cc2828a0701d749ef328b577ba2f6e924d0
EBUILD skypeforlinux-8.94.0.428.ebuild 3250 BLAKE2B 760f4a7ffe0493541d0b941ee83cf0ce99150ee90aadcbe4ad2f244fad2b0df5218e240500428f4da3d40ca7a586e135878083d2c4173fd00009f50fa91641b7 SHA512 cdacf86cd0534a1f2d204dbeaf689f2e62903308561fe68b88d981f5c985eaa16d1057226e786e243c87d48619a77cc2828a0701d749ef328b577ba2f6e924d0
EBUILD skypeforlinux-8.95.0.408.ebuild 3196 BLAKE2B c1b6996e82bc414acfbf6850ba4a9c17a72d12dd10f82fbc081d8740152bcf694f451e5010a5568145b229b2ac8c080dbf773102b8cc033e585e7cf2d944b4d2 SHA512 d4d3a99227d967bea5dcd4c89fc52cf737cfa056bebc3244acf4121971308871576af48ef5344f070e1e165eac88fe425bb44ddfef29ab52db967a1664619ed9
+EBUILD skypeforlinux-8.96.0.207.ebuild 3196 BLAKE2B c1b6996e82bc414acfbf6850ba4a9c17a72d12dd10f82fbc081d8740152bcf694f451e5010a5568145b229b2ac8c080dbf773102b8cc033e585e7cf2d944b4d2 SHA512 d4d3a99227d967bea5dcd4c89fc52cf737cfa056bebc3244acf4121971308871576af48ef5344f070e1e165eac88fe425bb44ddfef29ab52db967a1664619ed9
MISC metadata.xml 461 BLAKE2B 9bcbfe1d6892c40ce917a76c600baad338b5b86967e5656f79b9bf29e75c3ba474dc11444d8e347769f37934610a971097f96b22ae171ea46cd3f1aef2e9f3e5 SHA512 81df3ef175eafabad357f3d5792c71534b85ffd2c1bd9280ea7ef9cbea17aceb396bc7ac65abdb09e5fba8c3d98384c0d67c58a8daa2d42a657e1a7b150b52e7
diff --git a/net-im/skypeforlinux/skypeforlinux-8.96.0.207.ebuild b/net-im/skypeforlinux/skypeforlinux-8.96.0.207.ebuild
new file mode 100644
index 000000000000..4dc00a3d1aec
--- /dev/null
+++ b/net-im/skypeforlinux/skypeforlinux-8.96.0.207.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit chromium-2 desktop pax-utils rpm multilib-build xdg
+
+DESCRIPTION="Instant messaging client, with support for audio and video"
+HOMEPAGE="https://www.skype.com/"
+SRC_URI="https://repo.skype.com/rpm/stable/${PN}_${PV}-1.x86_64.rpm"
+S="${WORKDIR}"
+
+LICENSE="Skype-TOS MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 Boost-1.0 ISC CC-BY-SA-3.0 CC0-1.0 openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+QA_PREBUILT="*"
+RESTRICT="mirror bindist strip" #299368
+
+RDEPEND="
+ app-crypt/libsecret[${MULTILIB_USEDEP}]
+ app-accessibility/at-spi2-core:2[${MULTILIB_USEDEP}]
+ dev-libs/expat[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr[${MULTILIB_USEDEP}]
+ dev-libs/nss[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
+ media-libs/freetype:2[${MULTILIB_USEDEP}]
+ media-libs/libv4l[${MULTILIB_USEDEP}]
+ net-print/cups[${MULTILIB_USEDEP}]
+ sys-apps/dbus[${MULTILIB_USEDEP}]
+ sys-devel/gcc[cxx]
+ sys-libs/glibc
+ virtual/ttf-fonts
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXScrnSaver[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libxcb[${MULTILIB_USEDEP}]
+ x11-libs/libxkbcommon[${MULTILIB_USEDEP}]
+ x11-libs/libxkbfile[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]"
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ rpm_src_unpack ${A}
+}
+
+src_prepare() {
+ default
+ sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
+ -i usr/bin/skypeforlinux || die
+ sed -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
+ -e "/^OnlyShowIn=/d" \
+ -i usr/share/applications/skypeforlinux.desktop || die
+}
+
+src_install() {
+ dodir /opt
+ cp -a usr/share/skypeforlinux "${ED}"/opt || die
+
+ # remove chrome-sandbox binary, users should use kernel namespaces
+ # https://bugs.gentoo.org/692692#c18
+ rm "${ED}"/opt/skypeforlinux/chrome-sandbox || die
+
+ dobin usr/bin/skypeforlinux
+
+ dodoc usr/share/skypeforlinux/*.html
+ dodoc -r usr/share/doc/skypeforlinux/.
+ # symlink required for the "Help->3rd Party Notes" menu entry (otherwise frozen skype -> xdg-open)
+ dosym ${PF} usr/share/doc/skypeforlinux
+
+ doicon usr/share/pixmaps/skypeforlinux.png
+
+ local res
+ for res in 16 32 256 512; do
+ newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
+ done
+
+ domenu usr/share/applications/skypeforlinux.desktop
+
+ pax-mark -m "${ED}"/opt/skypeforlinux/skypeforlinux
+ pax-mark -m "${ED}"/opt/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
+}