summaryrefslogtreecommitdiff
path: root/net-im/skypeforlinux
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/skypeforlinux')
-rw-r--r--net-im/skypeforlinux/Manifest5
-rw-r--r--net-im/skypeforlinux/skypeforlinux-8.52.0.138-r1.ebuild107
-rw-r--r--net-im/skypeforlinux/skypeforlinux-8.52.0.138.ebuild (renamed from net-im/skypeforlinux/skypeforlinux-8.51.0.92.ebuild)6
3 files changed, 115 insertions, 3 deletions
diff --git a/net-im/skypeforlinux/Manifest b/net-im/skypeforlinux/Manifest
index 530a66297e34..1aa561d280f3 100644
--- a/net-im/skypeforlinux/Manifest
+++ b/net-im/skypeforlinux/Manifest
@@ -1,3 +1,4 @@
-DIST skypeforlinux_8.51.0.92-1.x86_64.rpm 106489251 BLAKE2B 1846623eb9ab78bf143b9a45bf2001fb3ae4b78ac1690041b984f96f309f57ac427f1313722de02d3305cab4413f40470a9452f1d87a47b3e3af1d0878eecabb SHA512 58c86e19900badec28e0bc58ed23459aea8e94e6f0d36fd8d8412d99d96eec15945a9b4920278788e5edccc6cc26ec7da9159d7105ff4499f9c6e44d3e4615ac
-EBUILD skypeforlinux-8.51.0.92.ebuild 3290 BLAKE2B 6ba778ac15813855972a0f8a7841186e23b42766a465db44c825b699cf79e5a399c540c71ec0705b243bbe08c73c02efc9077495c4cf1f77edd8ef6e07463171 SHA512 50e044c7e7e5ae986d8465e9842dc8aebf8a888076c192ad4fcb0597010da224358f2ea7bf2e9de0f29108c6ae4563b6bc2af0337d29e2c45303d77a5f707b48
+DIST skypeforlinux_8.52.0.138-1.x86_64.rpm 106539045 BLAKE2B f07275b050ef63f87dfe54633ffa8446c5aa7a3db40e1eeea9c0902e9f7726fab59c7c1e55fd7af9b3f92bfb87a90b74851eeb334e415ed3b90f20013eda2b25 SHA512 dffb71138116c7c657a16cb7811e201d70b8d41242d3f1616f7e1ac71d6db60db487184b241b8290e4aa61fe755555b470db5731b269afd1d81c502e42bc31e7
+EBUILD skypeforlinux-8.52.0.138-r1.ebuild 3386 BLAKE2B e0179a6f27b7cc70b035d027be82f0737cb7ff83c27e45e413398272341824a1112ebd85f21b2867a49018947137dc721f7c3483311c33d5af8418d2458f82ef SHA512 e8e481cc3f57bc72934e73157bf1d38c8e2c1bc2588c63e040dbd868233474ad6b0ec41fc3d648e83265a485844fa93dee20fa79036a01b4f6d674c621a47232
+EBUILD skypeforlinux-8.52.0.138.ebuild 3361 BLAKE2B 5c809d77664d17b07bad0a873c39cac43583645f3a1c2d1298cfb25587edc4e3b425ed168584e4f41a73cab5a492c21a3d7767a1ac724b7495e7fd95348d8d7e SHA512 e6814ef8e863aa741959c1797bb07ef6fef3aff307ec475283a95f0df5278b2ea7170a7e21cca5e10d17b9674c89e5e1a1b82fbe4520c9bcb0fde7e7bb8de916
MISC metadata.xml 786 BLAKE2B 3041105c7b5f90dc5f058e92a8542550b1c07fe954a68c0fdad069b309f41a75d1885ef14d62b3bb8defa7b69a4478a3ec37abb09a16153614d498d82877958c SHA512 2332db6f8ec755f6b12c4bef3b7e5819438a38835ad764bbf3466f1560905024f2632fc7035904028fbddc6c368930fcea81bb10f29dec1b9725b658d81208ca
diff --git a/net-im/skypeforlinux/skypeforlinux-8.52.0.138-r1.ebuild b/net-im/skypeforlinux/skypeforlinux-8.52.0.138-r1.ebuild
new file mode 100644
index 000000000000..7e1b0f86ef82
--- /dev/null
+++ b/net-im/skypeforlinux/skypeforlinux-8.52.0.138-r1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit chromium-2 desktop pax-utils rpm multilib-build xdg
+
+DESCRIPTION="Instant messaging client, with support for audio and video"
+HOMEPAGE="https://www.skype.com/"
+SRC_URI="https://repo.skype.com/rpm/stable/${PN}_${PV}-1.x86_64.rpm"
+
+LICENSE="Skype-TOS MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 Boost-1.0 ISC CC-BY-SA-3.0 CC0-1.0 openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="pax_kernel"
+
+S="${WORKDIR}"
+QA_PREBUILT="*"
+RESTRICT="mirror bindist strip" #299368
+
+RDEPEND="
+ || (
+ sys-auth/elogind
+ sys-apps/systemd
+ net-im/skype-dbus-mock
+ )
+ app-crypt/libsecret[${MULTILIB_USEDEP}]
+ dev-libs/atk[${MULTILIB_USEDEP}]
+ dev-libs/expat[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr[${MULTILIB_USEDEP}]
+ dev-libs/nss[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
+ media-libs/freetype:2[${MULTILIB_USEDEP}]
+ media-libs/libv4l[${MULTILIB_USEDEP}]
+ net-print/cups[${MULTILIB_USEDEP}]
+ sys-apps/dbus[${MULTILIB_USEDEP}]
+ sys-devel/gcc[cxx]
+ virtual/ttf-fonts
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXScrnSaver[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libxcb[${MULTILIB_USEDEP}]
+ x11-libs/libxkbfile[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]"
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ rpm_src_unpack ${A}
+}
+
+src_prepare() {
+ default
+ sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
+ -i usr/bin/skypeforlinux || die
+ sed -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
+ -e "/^OnlyShowIn=/d" \
+ -i usr/share/applications/skypeforlinux.desktop || die
+}
+
+src_install() {
+ dodir /opt
+ cp -a usr/share/skypeforlinux "${D}"/opt || die
+
+ dobin usr/bin/skypeforlinux
+
+ dodoc usr/share/skypeforlinux/*.html
+ dodoc -r usr/share/doc/skypeforlinux/.
+ # symlink required for the "Help->3rd Party Notes" menu entry (otherwise frozen skype -> xdg-open)
+ dosym ${PF} usr/share/doc/skypeforlinux
+
+ doicon usr/share/pixmaps/skypeforlinux.png
+
+ local res
+ for res in 16 32 256 512; do
+ newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
+ done
+
+ domenu usr/share/applications/skypeforlinux.desktop
+
+ if use pax_kernel; then
+ pax-mark -m "${ED}"/opt/skypeforlinux/skypeforlinux
+ pax-mark -m "${ED}"/opt/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
+ ewarn "You have set USE=pax_kernel meaning that you intend to run"
+ ewarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+ ewarn "the ${PN} binary itself and this *may* lead to breakage! If"
+ ewarn "you suspect that ${PN} is being broken by this modification,"
+ ewarn "please open a bug."
+ fi
+}
diff --git a/net-im/skypeforlinux/skypeforlinux-8.51.0.92.ebuild b/net-im/skypeforlinux/skypeforlinux-8.52.0.138.ebuild
index df398450e030..68c053c717f7 100644
--- a/net-im/skypeforlinux/skypeforlinux-8.51.0.92.ebuild
+++ b/net-im/skypeforlinux/skypeforlinux-8.52.0.138.ebuild
@@ -5,7 +5,7 @@ EAPI=7
MULTILIB_COMPAT=( abi_x86_64 )
-inherit desktop pax-utils rpm multilib-build xdg
+inherit chromium-2 desktop pax-utils rpm multilib-build xdg
DESCRIPTION="Instant messaging client, with support for audio and video"
HOMEPAGE="https://www.skype.com/"
@@ -57,6 +57,10 @@ RDEPEND="
x11-libs/libxkbfile[${MULTILIB_USEDEP}]
x11-libs/pango[${MULTILIB_USEDEP}]"
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
src_unpack() {
rpm_src_unpack ${A}
}