summaryrefslogtreecommitdiff
path: root/net-im/sendxmpp-amm/sendxmpp-amm-1.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/sendxmpp-amm/sendxmpp-amm-1.1.1.ebuild')
-rw-r--r--net-im/sendxmpp-amm/sendxmpp-amm-1.1.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-im/sendxmpp-amm/sendxmpp-amm-1.1.1.ebuild b/net-im/sendxmpp-amm/sendxmpp-amm-1.1.1.ebuild
new file mode 100644
index 000000000000..700d92138fdb
--- /dev/null
+++ b/net-im/sendxmpp-amm/sendxmpp-amm-1.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ORIG_PN="${PN%-amm}"
+
+DESCRIPTION="Send XMPP (Jabber) messages via command line"
+HOMEPAGE="https://github.com/flowdalic/sendxmpp"
+
+if [[ "${PV}" == "9999" ]] || [[ -n "${EGIT_COMMIT_ID}" ]]; then
+ EGIT_REPO_URI="https://github.com/Flowdalic/${ORIG_PN}.git"
+ inherit git-r3
+ if [[ "${PV}" == "9999" ]]; then
+ MY_KEYWORDS=""
+ fi
+else
+ SRC_URI="https://github.com/flowdalic/${ORIG_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${ORIG_PN}-${PV}"
+fi
+
+LICENSE="GPL-3+"
+
+SLOT="0"
+
+RDEPEND="
+ dev-lang/ammonite-repl-bin
+ !net-im/sendxmpp
+"
+
+src_install() {
+ default
+ dobin sendxmpp
+}