summaryrefslogtreecommitdiff
path: root/net-im/qtox/qtox-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/qtox/qtox-9999.ebuild')
-rw-r--r--net-im/qtox/qtox-9999.ebuild26
1 files changed, 9 insertions, 17 deletions
diff --git a/net-im/qtox/qtox-9999.ebuild b/net-im/qtox/qtox-9999.ebuild
index 955d7a8edce1..c2f80f279d6f 100644
--- a/net-im/qtox/qtox-9999.ebuild
+++ b/net-im/qtox/qtox-9999.ebuild
@@ -1,21 +1,25 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils eutils git-r3 gnome2-utils xdg-utils
+inherit cmake git-r3 xdg
DESCRIPTION="Most feature-rich GUI for net-libs/tox using Qt5"
HOMEPAGE="https://github.com/qTox/qTox"
-SRC_URI=""
EGIT_REPO_URI="https://github.com/qTox/qTox.git"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS=""
IUSE="notification test X"
+
RESTRICT="!test? ( test )"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
RDEPEND="
dev-db/sqlcipher
dev-libs/libsodium:=
@@ -38,13 +42,11 @@ RDEPEND="
x11-libs/libXScrnSaver )
"
DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
- virtual/pkgconfig
test? ( dev-qt/qttest:5 )
"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# bug 628574
if ! use test; then
@@ -61,15 +63,5 @@ src_configure() {
-DUSE_FILTERAUDIO=OFF
)
- cmake-utils_src_configure
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
+ cmake_src_configure
}