summaryrefslogtreecommitdiff
path: root/net-im/neochat/neochat-1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/neochat/neochat-1.0.1.ebuild')
-rw-r--r--net-im/neochat/neochat-1.0.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-im/neochat/neochat-1.0.1.ebuild b/net-im/neochat/neochat-1.0.1.ebuild
new file mode 100644
index 000000000000..a0220e2f6541
--- /dev/null
+++ b/net-im/neochat/neochat-1.0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.77.0
+QTMIN=5.15.1
+inherit ecm kde.org
+
+DESCRIPTION="Client for Matrix, the decentralized communication protocol"
+HOMEPAGE="https://apps.kde.org/en/neochat"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="
+ app-text/cmark:=
+ dev-libs/qtkeychain:=
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtmultimedia-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ media-libs/kquickimageeditor:5
+ net-libs/libquotient
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtgraphicaleffects-${QTMIN}:5
+ >=dev-qt/qtmultimedia-${QTMIN}:5[qml]
+ >=kde-frameworks/kitemmodels-${KFMIN}:5[qml]
+"
+BDEPEND="
+ virtual/pkgconfig
+"