summaryrefslogtreecommitdiff
path: root/net-im/libcommuni
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/libcommuni')
-rw-r--r--net-im/libcommuni/Manifest2
-rw-r--r--net-im/libcommuni/libcommuni-3.5.0_p20190110.ebuild84
2 files changed, 86 insertions, 0 deletions
diff --git a/net-im/libcommuni/Manifest b/net-im/libcommuni/Manifest
index b56695ad7340..418814d27f37 100644
--- a/net-im/libcommuni/Manifest
+++ b/net-im/libcommuni/Manifest
@@ -1,3 +1,5 @@
DIST libcommuni-3.5.0_p20180116.tar.gz 471286 BLAKE2B 9f89a5eea2444c207b54f6b820c7cef89ff2e578d34ad751fdbfe558af2bcf0e52238ef63b244fb321baa7716c0119ca084c547cc0161a08b46af4c9d604dd0e SHA512 f7ce9c92acbd67b3d75b9b7fc1cef55796a3d44294024da591c7b0c21fc065ec484dbc6a4c83af96fcb6fd6e725a7b6ed4219bd09e2aa0de303b82d64741efba
+DIST libcommuni-3.5.0_p20190110.tar.gz 471278 BLAKE2B 2836a5ae01b08aac624c899a40712a9c452fc5b8f242906063936e48bd59306758cc70ea07beaf8488d228d6029c8128e343bbd59b1bfeff9bb2dccda0153b59 SHA512 9da065ef6b0589f7406d8c66b46f9f8d3d16325b59b7281153233b1a8d2bf98cdd35ee4e416237ac760dfc07531578aa7432226932976b9bbf36209bed5db72c
EBUILD libcommuni-3.5.0_p20180116.ebuild 2128 BLAKE2B 386bde06275955c0f41149742125ba553b9b08a412d364224521a89a45d79ec37424a30d6dd5411e3ba038745329fcc5c2cd44c781f3e72e9adf18bdae53d660 SHA512 e7eb98f39b9a8fed2034eea56d4f09a15bc3688cae2a024fd96b352cbc61a6de70db43d0b92354b331a80e8087844608610ac79a541bd17b827115ec7d405eb9
+EBUILD libcommuni-3.5.0_p20190110.ebuild 2363 BLAKE2B e36ab025ba99e1a6e0adbd6d1506f699d83f40d91fe0859ecb03d084a5889c2543035e342e11a4d9c64ae93df2f7d605e805379e840303c6c28592f461642204 SHA512 99e1b66dd7b3da62267f81198ed20796daa3a0ff859b1f1b90def427e2321e1823210c08a85ec0ba8aba39bb649b9ac5c8692272585ec07fc2dce9e4af6c3294
MISC metadata.xml 797 BLAKE2B 9dc5a8109d9b5421c2ae2b8fa49bef5012107e5356975fe3ec2879bf02395d0762b370400c19a9bcefb90583b985c91bfcc42b934849b964496b2857640bccc2 SHA512 61814cbb96bb1a263bdecdba5adf4620dd35d9444065499af20523674573c9297ea39f52b740e7bf19cabf6cb63a116209f95a9a6edc4d25fe7d2966c9e36d7e
diff --git a/net-im/libcommuni/libcommuni-3.5.0_p20190110.ebuild b/net-im/libcommuni/libcommuni-3.5.0_p20190110.ebuild
new file mode 100644
index 000000000000..484a8cc0e917
--- /dev/null
+++ b/net-im/libcommuni/libcommuni-3.5.0_p20190110.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_COMMIT="88bb0fcdaab5bdd1176a3b6b485a6415a137ec27"
+
+inherit qmake-utils
+
+DESCRIPTION="A cross-platform IRC framework written with Qt"
+HOMEPAGE="https://communi.github.io/"
+SRC_URI="https://github.com/communi/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples qml test +uchardet"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ examples? ( dev-qt/qtgui:5[xcb] )
+ uchardet? ( app-i18n/uchardet )
+ !uchardet? ( dev-libs/icu:= )
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+src_prepare() {
+ default
+
+ # Currently the test tst_IrcLagTimer fails, so disabling
+ # See: https://github.com/communi/libcommuni/issues/63
+ sed -e '/irclagtimer/d' -i tests/auto/auto.pro || die
+}
+
+src_configure() {
+ local myqmakeargs=( libcommuni.pro
+ # Disables compile run-time benchmarks, as they don't make any sense
+ -config no_benchmarks
+ # Is needed for fixing the QA Notice: The following files contain insecure RUNPATHs
+ -config no_rpath
+ # Compile libcommuni always in Release mode, as Debug seems to do nothing
+ -config release
+ # Don't silence all compile messages
+ -config verbose
+ -config $(usex examples '' 'no_')examples
+ -config $(usex qml '' 'no_')install_imports
+ -config $(usex qml '' 'no_')install_qml
+ -config $(usex test '' 'no_')tests
+ -config $(usex uchardet 'no_' '')icu
+ -config $(usex uchardet '' 'no_')uchardet )
+
+ eqmake5 "${myqmakeargs[@]}"
+}
+
+src_test() {
+ # This is a hack to delete the existing LD_LIBRARY_PATH and set a new one,
+ # otherwise a test will fail, because it uses the system installed lib instead of the new compiled lib.
+ # The test will fail, when libcommuni is emerged with USE="uchardet" and
+ # libcommuni is already installed with USE="-uchardat", or the other way around.
+ find "${S}" -type f -name 'target_wrapper.sh' -exec sed -i -e "/.*LD_LIBRARY_PATH.*/d" {} \; || die
+ local -x LD_LIBRARY_PATH="${S}/lib"
+
+ default
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+
+ if use examples; then
+ local examples=( "bot" "client" "minimal" "qmlbot" "quick" )
+ for example in ${examples[@]}; do
+ newbin examples/"${example}"/"${example}" libcommuni."${example}"
+ done
+ fi
+
+ einstalldocs
+}