summaryrefslogtreecommitdiff
path: root/net-ftp/vsftpd/files
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/vsftpd/files')
-rw-r--r--net-ftp/vsftpd/files/vsftpd-3.0.5-fix-link-command.patch25
-rw-r--r--net-ftp/vsftpd/files/vsftpd.init-3.0.519
-rw-r--r--net-ftp/vsftpd/files/vsftpd.service-3.0.510
-rw-r--r--net-ftp/vsftpd/files/vsftpd.xinetd4
-rw-r--r--net-ftp/vsftpd/files/vsftpd_at.service-3.0.57
5 files changed, 63 insertions, 2 deletions
diff --git a/net-ftp/vsftpd/files/vsftpd-3.0.5-fix-link-command.patch b/net-ftp/vsftpd/files/vsftpd-3.0.5-fix-link-command.patch
new file mode 100644
index 000000000000..a4560a8ef6b9
--- /dev/null
+++ b/net-ftp/vsftpd/files/vsftpd-3.0.5-fix-link-command.patch
@@ -0,0 +1,25 @@
+From 5c00346f72de5b966ebb0841c87a22c6b11c1b38 Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Thu, 12 Aug 2021 16:51:55 -0400
+Subject: [PATCH] Fix link command
+
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index c63ed1b..c3454c3 100644
+--- a/Makefile
++++ b/Makefile
+@@ -26,7 +26,7 @@ OBJS = main.o utility.o prelogin.o ftpcmdio.o postlogin.o privsock.o \
+ $(CC) -c $*.c $(CFLAGS) $(IFLAGS)
+
+ vsftpd: $(OBJS)
+- $(CC) -o vsftpd $(OBJS) $(LINK) $(LDFLAGS) $(LIBS)
++ $(CC) -o vsftpd $(CFLAGS) $(LDFLAGS) $(OBJS) $(LIBS)
+
+ install:
+ if [ -x /usr/local/sbin ]; then \
+--
+2.32.0
+
diff --git a/net-ftp/vsftpd/files/vsftpd.init-3.0.5 b/net-ftp/vsftpd/files/vsftpd.init-3.0.5
new file mode 100644
index 000000000000..cc9ad7f4a803
--- /dev/null
+++ b/net-ftp/vsftpd/files/vsftpd.init-3.0.5
@@ -0,0 +1,19 @@
+#!/sbin/openrc-run
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License, v2
+
+instance=${RC_SVCNAME#*.}
+
+: ${command=/usr/sbin/vsftpd}
+command_background=true
+
+if [ "${instance}" = "${RC_SVCNAME}" ]; then
+ : ${pidfile=/run/vsftpd.pid}
+else
+ : ${command_args=/etc/vsftpd/${instance}.conf}
+ : ${pidfile=/run/vsftpd.${instance}.pid}
+fi
+
+depend() {
+ use dns logger net
+}
diff --git a/net-ftp/vsftpd/files/vsftpd.service-3.0.5 b/net-ftp/vsftpd/files/vsftpd.service-3.0.5
new file mode 100644
index 000000000000..209b36636d55
--- /dev/null
+++ b/net-ftp/vsftpd/files/vsftpd.service-3.0.5
@@ -0,0 +1,10 @@
+[Unit]
+Description=Very Secure FTP Daemon
+After=network.target
+
+[Service]
+Type=simple
+ExecStart=/usr/sbin/vsftpd
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-ftp/vsftpd/files/vsftpd.xinetd b/net-ftp/vsftpd/files/vsftpd.xinetd
index efa4ff2feee8..a4ac0211d212 100644
--- a/net-ftp/vsftpd/files/vsftpd.xinetd
+++ b/net-ftp/vsftpd/files/vsftpd.xinetd
@@ -1,5 +1,5 @@
# default: off
-# description: Vsftpd is an FTP server, designed to be secure.
+# description: Very Secure FTP Daemon
service ftp
{
@@ -7,7 +7,7 @@ service ftp
wait = no
user = root
server = /usr/sbin/vsftpd
- server_args = /etc/vsftpd/vsftpd.conf
+ server_args = -olisten=NO
log_on_success += DURATION
nice = 10
disable = yes
diff --git a/net-ftp/vsftpd/files/vsftpd_at.service-3.0.5 b/net-ftp/vsftpd/files/vsftpd_at.service-3.0.5
new file mode 100644
index 000000000000..d06c92f4e9fa
--- /dev/null
+++ b/net-ftp/vsftpd/files/vsftpd_at.service-3.0.5
@@ -0,0 +1,7 @@
+[Unit]
+Description=Very Secure FTP Daemon
+
+[Service]
+Type=simple
+ExecStart=/usr/sbin/vsftpd -olisten=NO
+StandardInput=socket