summaryrefslogtreecommitdiff
path: root/net-ftp/tnftp/tnftp-20230409.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/tnftp/tnftp-20230409.ebuild')
-rw-r--r--net-ftp/tnftp/tnftp-20230409.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-ftp/tnftp/tnftp-20230409.ebuild b/net-ftp/tnftp/tnftp-20230409.ebuild
new file mode 100644
index 000000000000..596d018dbd6d
--- /dev/null
+++ b/net-ftp/tnftp/tnftp-20230409.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DESCRIPTION="NetBSD FTP client with several advanced features"
+SRC_URI="ftp://ftp.netbsd.org/pub/NetBSD/misc/${PN}/${P}.tar.gz"
+HOMEPAGE="ftp://ftp.netbsd.org/pub/NetBSD/misc/tnftp/"
+
+SLOT="0"
+LICENSE="BSD-4 BSD ISC"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="ipv6 socks5 ssl"
+REQUIRED_USE="socks5? ( !ipv6 )"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ dev-libs/libedit
+ socks5? ( net-proxy/dante )
+ ssl? ( dev-libs/openssl:= )"
+RDEPEND="${DEPEND}"
+
+DOCS=( ChangeLog README THANKS )
+
+src_configure() {
+ econf \
+ --enable-editcomplete \
+ --without-local-libedit \
+ $(use_enable ipv6) \
+ $(use_enable ssl) \
+ $(use_with socks5 socks)
+}