summaryrefslogtreecommitdiff
path: root/net-ftp/tftp-hpa
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/tftp-hpa')
-rw-r--r--net-ftp/tftp-hpa/Manifest3
-rw-r--r--net-ftp/tftp-hpa/metadata.xml4
-rw-r--r--net-ftp/tftp-hpa/tftp-hpa-5.2-r2.ebuild78
3 files changed, 84 insertions, 1 deletions
diff --git a/net-ftp/tftp-hpa/Manifest b/net-ftp/tftp-hpa/Manifest
index a3fc137dfe06..77baa1f22f4a 100644
--- a/net-ftp/tftp-hpa/Manifest
+++ b/net-ftp/tftp-hpa/Manifest
@@ -6,4 +6,5 @@ AUX tftp.socket 112 BLAKE2B 11e8c6e77819ba772b709843af11449e768db16fe866dc67e420
AUX tftp.xinetd 219 BLAKE2B d348f13fdfa749b10ec765d5cd90a65a46d266a132dde47dad00fbd1ef4046c250cd9246e7b1fe9590e974a2bc7fcc817535fd2e9447a10c5286f7c4148eec93 SHA512 26883a4feffe8f66fe2c21c05892beeb93fa4511ca5ce18e92273badd4b93afefb0d9cef48e07503037ca37b2ff0cdb24d35e5c24d2e32d8027a5e74c49426f5
DIST tftp-hpa-5.2.tar.xz 89564 BLAKE2B 45917ca3d710f8a4b584dbe1e9a912e06fd181e4ffcfd8fba13008f08dbbce0fe339b61fb6f97236b8012e755025d05700214e365adac81dfce42b0edd636e80 SHA512 a5198e923a6e58281f749dc77b3f3ed8579e56b6f0fd6a17482cc88bdc8d34b6702c7c709717885b9b937ecae459d9a832328a49a2e3536dc7432cdb39d2a394
EBUILD tftp-hpa-5.2-r1.ebuild 1359 BLAKE2B 8d23615339df9e236c357bc31ec30787fb41910abc4806e4bdb411aec60c2294d357e9a3fa580eec8c3708046eab84eac507b2327ed71bc11f59bddd73e69236 SHA512 7ab446cc7bef3cd7a6826e85e0967a32d2819537c48146412aa9b54562ff0bda3c6a3e63706ffc1836a6c89611263b1e4ab5749204cc00178f467b802fac1b52
-MISC metadata.xml 253 BLAKE2B 295e9d6d93aaa12af413972e1590c67087801cc09c9aa6b59d4606c0f4106d1dacf2baa9858559083b4c6d91beeef218d0729e8593a33788958da6d2897e8ce2 SHA512 54a9069aeb4165d2dff3d473c8001bc51613aac9dff3f7f5e9971a9891a737a31511ffa11cbd523febe581ac1d9de2bdf2f40410f0c4239138f2ccca3ef15555
+EBUILD tftp-hpa-5.2-r2.ebuild 1619 BLAKE2B 3b6709d1c7ec574a4815a5f587063488b5a1b4f274ea7e9a9204549e89366510d7061011ee17f89eeecbad15d55dfdade8dcd122f5e40b017597acd17e4c208c SHA512 560062a79372b0ad40ca5fab781e0947fef99e884a719d4d932a31509b087911871e8b2d16de8cd5a6f2e2d2afe9a8200a37c5ca93a7fa211fa180987ead7348
+MISC metadata.xml 394 BLAKE2B 87202528ec85f2d4931e861cbb0ee6a69653502c2ab33ae5def46e32786cff1fa90b5102546254a03f71c84c970757591da6f883e49f63580ccca837f8c5181e SHA512 0a866135a65f2c41c97a5991a4f041989a5c9b13c74cf327a3a6ec66d1589da64f31f2d8ec2f3848ecd32faebb790092a39a33f1806335b2f267e41501209321
diff --git a/net-ftp/tftp-hpa/metadata.xml b/net-ftp/tftp-hpa/metadata.xml
index 56c124413057..e56bfe22863a 100644
--- a/net-ftp/tftp-hpa/metadata.xml
+++ b/net-ftp/tftp-hpa/metadata.xml
@@ -5,4 +5,8 @@
<email>base-system@gentoo.org</email>
<name>Gentoo Base System</name>
</maintainer>
+<use>
+ <flag name="client">Compile and install the tftp client</flag>
+ <flag name="server">Compile and install the tftp server</flag>
+</use>
</pkgmetadata>
diff --git a/net-ftp/tftp-hpa/tftp-hpa-5.2-r2.ebuild b/net-ftp/tftp-hpa/tftp-hpa-5.2-r2.ebuild
new file mode 100644
index 000000000000..3381ec42a76b
--- /dev/null
+++ b/net-ftp/tftp-hpa/tftp-hpa-5.2-r2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="port of the OpenBSD TFTP server"
+HOMEPAGE="https://www.kernel.org/pub/software/network/tftp/"
+SRC_URI="https://www.kernel.org/pub/software/network/tftp/${PN}/${P}.tar.xz"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-macos"
+IUSE="ipv6 readline selinux tcpd +client +server"
+
+DEPEND="
+ readline? ( sys-libs/readline:0= )
+ tcpd? ( sys-apps/tcp-wrappers )
+"
+
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-tftp )
+ !net-ftp/atftp
+ !net-ftp/uftpd
+ server? ( !net-misc/iputils[tftpd(+)] )
+"
+
+PATCHES=(
+ "${FILESDIR}"/tftp-hpa-5.2-gcc-10.patch
+)
+
+src_prepare() {
+ default
+ sed -i "/^AR/s:ar:$(tc-getAR):" MCONFIG.in || die
+}
+
+src_configure() {
+ local myconf=(
+ ac_cv_search_bsd_signal=no
+ $(use_with ipv6)
+ $(use_with tcpd tcpwrappers)
+ $(use_with readline)
+ )
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake version.h
+ emake -C lib
+ emake -C common
+ if use client; then
+ emake -C tftp
+ fi
+ if use server; then
+ emake -C tftpd
+ fi
+}
+
+src_install() {
+ dodoc README* CHANGES tftpd/sample.rules
+
+ if use client; then
+ emake INSTALLROOT="${D}" -C tftp install
+ fi
+ if use server; then
+ emake INSTALLROOT="${D}" -C tftpd install
+
+ newconfd "${FILESDIR}"/in.tftpd.confd-0.44 in.tftpd
+ newinitd "${FILESDIR}"/in.tftpd.rc6 in.tftpd
+
+ systemd_dounit "${FILESDIR}"/tftp.service
+ systemd_dounit "${FILESDIR}"/tftp.socket
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/tftp.xinetd tftp
+ fi
+}