summaryrefslogtreecommitdiff
path: root/net-dns
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/Manifest.gzbin8374 -> 8373 bytes
-rw-r--r--net-dns/libidn2/Manifest2
-rw-r--r--net-dns/libidn2/libidn2-2.3.4.ebuild11
3 files changed, 10 insertions, 3 deletions
diff --git a/net-dns/Manifest.gz b/net-dns/Manifest.gz
index d319bac921c2..88487e640fb3 100644
--- a/net-dns/Manifest.gz
+++ b/net-dns/Manifest.gz
Binary files differ
diff --git a/net-dns/libidn2/Manifest b/net-dns/libidn2/Manifest
index 4f72e4382300..0b04573023f1 100644
--- a/net-dns/libidn2/Manifest
+++ b/net-dns/libidn2/Manifest
@@ -1,4 +1,4 @@
DIST libidn2-2.3.4.tar.gz 2083823 BLAKE2B 26ef58894ad51ca9775cf07edb1353a8aeb7af0df36ce8698425be216a067903797cdbc50c7644292c7e05b23c7bba35c9fe5e38c70e6f55784d8bcdd9c2fdb2 SHA512 a6e90ccef56cfd0b37e3333ab3594bb3cec7ca42a138ca8c4f4ce142da208fa792f6c78ca00c01001c2bc02831abcbaf1cf9bcc346a5290fd7b30708f5a462f3
DIST libidn2-2.3.4.tar.gz.sig 228 BLAKE2B 0aa25bbd58b76724dc7f6d7a40dd578bf28f4b786c32933fae330c4330da8fabd549c45b579bfc0ef0178b10122e59c6b33bd78a8425c744dff2ace7e75018dd SHA512 d2a575723326ae256a60e3edf7766af65434f716e11f963bb7ac29b6b2ff2872b41684a1bd1c6f3a3921e8a083512eff1faf2b0fc02513095c2bcf3563312fe0
-EBUILD libidn2-2.3.4.ebuild 1366 BLAKE2B a2dad6524f0be69ac65294b3daf04f293977787093095be0c4b04a74aed70217751a216e27a54de2cf84e16d44f078deb0ae08fa7e7cbbd334e6ebb772894114 SHA512 80a70481deedca85bbc565f4c45699cbfd6ceebd4880ef15c2b2c721d03d0747fd4ee08cc7c8795a556680df1d32670ce98c920c2ed4256fa79bca1564859958
+EBUILD libidn2-2.3.4.ebuild 1640 BLAKE2B 648d8b3b72b54c2dd3c9269507c94dea79535364df9256a0c828155770f52c4e0c758cbffd4a995af6f83e0547aaca7950aa5212a5cd0a9d9def99d90af03642 SHA512 7fbb134115ae8f4844d13570e85eed37bcb8e73ed7c8b440634342ad8c96715fe424be589d36979aa2f0e9c39fe717f08daa2307ed5776d89503ce23eb210a9f
MISC metadata.xml 616 BLAKE2B 8f655a4bf8a19dc46ad2c171a185418193042a5d94e7819cf7366c543f2bab24150715c9966f653cf6efbe1bfcaf4c7f0f2d2bc2cc4c876456e07ef823005953 SHA512 2f23e3e9efc8cabc33337a6c19b0b5d627327538ba3b4e669cac7aa7b424362eae6630249ae162df4d03c833c094affb223f80ee7f914ea87655a45576a11f70
diff --git a/net-dns/libidn2/libidn2-2.3.4.ebuild b/net-dns/libidn2/libidn2-2.3.4.ebuild
index abe76b1078f5..7f65dd252bed 100644
--- a/net-dns/libidn2/libidn2-2.3.4.ebuild
+++ b/net-dns/libidn2/libidn2-2.3.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit multilib-minimal toolchain-funcs verify-sig
+inherit flag-o-matic multilib-minimal toolchain-funcs verify-sig
DESCRIPTION="An implementation of the IDNA2008 specifications (RFCs 5890, 5891, 5892, 5893)"
HOMEPAGE="
@@ -37,6 +37,13 @@ BDEPEND="
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/libidn.asc
multilib_src_configure() {
+ # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
+ # https://github.com/gentoo/gentoo/pull/28355
+ # mold needs this too but right now tc-ld-is-mold is also not available
+ if tc-ld-is-lld; then
+ append-ldflags -Wl,--undefined-version
+ fi
+
local myconf=(
CC_FOR_BUILD="$(tc-getBUILD_CC)"
$(use_enable static-libs static)