summaryrefslogtreecommitdiff
path: root/net-dns/resolvconf-symlink/resolvconf-symlink-0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/resolvconf-symlink/resolvconf-symlink-0.ebuild')
-rw-r--r--net-dns/resolvconf-symlink/resolvconf-symlink-0.ebuild30
1 files changed, 15 insertions, 15 deletions
diff --git a/net-dns/resolvconf-symlink/resolvconf-symlink-0.ebuild b/net-dns/resolvconf-symlink/resolvconf-symlink-0.ebuild
index d11ff4ab6257..782762cc845f 100644
--- a/net-dns/resolvconf-symlink/resolvconf-symlink-0.ebuild
+++ b/net-dns/resolvconf-symlink/resolvconf-symlink-0.ebuild
@@ -1,35 +1,34 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
DESCRIPTION="Make /etc/resolv.conf a symlink to a runtime-writable location"
-HOMEPAGE="https://www.gentoo.org"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
SRC_URI=""
+S=${WORKDIR}
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+symlink"
-S=${WORKDIR}
-
pkg_preinst() {
if use symlink; then
- if [[ -f "${ROOT}"etc/resolv.conf && ! -L "${ROOT}"etc/resolv.conf ]]
+ if [[ -f ${EROOT}/etc/resolv.conf && ! -L ${EROOT}/etc/resolv.conf ]]
then # migrate existing resolv.conf
- if [[ "$(head -n 1 "${ROOT}"etc/resolv.conf)" \
+ if [[ "$(head -n 1 "${EROOT}"/etc/resolv.conf)" \
!= "# Generated by "* ]]; then
- eerror "${ROOT}etc/resolv.conf seems not to be autogenerated."
+ eerror "${EROOT}/etc/resolv.conf seems not to be autogenerated."
eerror "Aborting build to avoid removing user data. If that file is supposed"
eerror "to be autogenerated, please remove it manually. Otherwise, please"
eerror "set USE=-symlink to avoid installing resolv.conf symlink."
- die "${ROOT}etc/resolv.conf not autogenerated"
+ die "${EROOT}/etc/resolv.conf not autogenerated"
else
- ebegin "Moving ${ROOT}etc/resolv.conf to ${ROOT}var/run/"
- mv "${ROOT}"etc/resolv.conf "${ROOT}"var/run/
+ ebegin "Moving ${EROOT}/etc/resolv.conf to ${EROOT}/var/run/"
+ mv "${EROOT}"/etc/resolv.conf "${EROOT}"/var/run/
eend ${?} || die
fi
fi
@@ -39,14 +38,15 @@ pkg_preinst() {
src_install() {
# XXX: /run should be more correct, when it's supported by baselayout
- use symlink && dosym /var/run/resolv.conf /etc/resolv.conf
+ use symlink && dosym ../var/run/resolv.conf /etc/resolv.conf
}
pkg_postrm() {
# Don't leave the user with no resolv.conf
- if [[ ! -e "${ROOT}"etc/resolv.conf && -f "${ROOT}"var/run/resolv.conf ]]; then
- ebegin "Moving ${ROOT}var/run/resolv.conf to ${ROOT}etc/"
- mv "${ROOT}"var/run/resolv.conf "${ROOT}"etc/
+ if [[ ! -e ${EROOT}/etc/resolv.conf && -f ${EROOT}/var/run/resolv.conf ]]
+ then
+ ebegin "Moving ${EROOT}/var/run/resolv.conf to ${EROOT}/etc/"
+ mv "${EROOT}"/var/run/resolv.conf "${EROOT}"/etc/
eend ${?} || die
fi
}