summaryrefslogtreecommitdiff
path: root/net-dns/dnshijacker/dnshijacker-1.3-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/dnshijacker/dnshijacker-1.3-r2.ebuild')
-rw-r--r--net-dns/dnshijacker/dnshijacker-1.3-r2.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/net-dns/dnshijacker/dnshijacker-1.3-r2.ebuild b/net-dns/dnshijacker/dnshijacker-1.3-r2.ebuild
index 6a23ca9c088c..2f9090042770 100644
--- a/net-dns/dnshijacker/dnshijacker-1.3-r2.ebuild
+++ b/net-dns/dnshijacker/dnshijacker-1.3-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="a libnet/libpcap based packet sniffer and spoofer"
HOMEPAGE="http://pedram.redhive.com/projects.php"
@@ -12,18 +12,16 @@ SRC_URI="http://pedram.redhive.com/downloads/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 x86"
-IUSE=""
-DEPEND="net-libs/libpcap
+DEPEND="
+ net-libs/libpcap
>=net-libs/libnet-1.0.2a-r3:1.0"
RDEPEND="${DEPEND}"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
-}
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
-src_compile() {
- emake CC=$(tc-getCC)
+src_configure() {
+ tc-export CC
}
src_install() {
@@ -32,5 +30,5 @@ src_install() {
insinto /etc/dnshijacker
doins ftable
- dodoc README
+ einstalldocs
}