summaryrefslogtreecommitdiff
path: root/net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild')
-rw-r--r--net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild21
1 files changed, 12 insertions, 9 deletions
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild
index f80bcb78727b..3e4c51ce549e 100644
--- a/net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild
+++ b/net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild
@@ -1,25 +1,28 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=8
+EAPI=7
-inherit fcaps go-module systemd
+EGO_PN="github.com/DNSCrypt/${PN}"
-DESCRIPTION="A flexible DNS proxy, with support for encrypted DNS protocols"
-HOMEPAGE="https://github.com/DNSCrypt/dnscrypt-proxy"
+inherit fcaps go-module systemd
if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://github.com/DNSCrypt/dnscrypt-proxy.git"
inherit git-r3
+ EGIT_REPO_URI="https://${EGO_PN}.git"
else
- SRC_URI="https://github.com/DNSCrypt/dnscrypt-proxy/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
fi
+DESCRIPTION="A flexible DNS proxy, with support for encrypted DNS protocols"
+HOMEPAGE="https://github.com/DNSCrypt/dnscrypt-proxy"
+
LICENSE="Apache-2.0 BSD ISC MIT MPL-2.0"
SLOT="0"
IUSE="+pie"
+BDEPEND=">=dev-lang/go-1.13"
RDEPEND="
acct-group/dnscrypt-proxy
acct-user/dnscrypt-proxy
@@ -28,7 +31,7 @@ RDEPEND="
FILECAPS=( cap_net_bind_service+ep usr/bin/dnscrypt-proxy )
PATCHES=(
- "${FILESDIR}"/${PN}-2.1.2-config-full-paths.patch
+ "${FILESDIR}/${PN}-2.1.0-config-full-paths.patch"
)
src_compile() {
@@ -93,7 +96,7 @@ pkg_postinst() {
fi
elog "After starting the service you will need to update your"
- elog "${EROOT}/etc/resolv.conf and replace your current set of resolvers"
+ elog "/etc/resolv.conf and replace your current set of resolvers"
elog "with:"
elog
elog "nameserver 127.0.0.1"