summaryrefslogtreecommitdiff
path: root/net-dns/c-ares
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/c-ares')
-rw-r--r--net-dns/c-ares/Manifest2
-rw-r--r--net-dns/c-ares/c-ares-1.17.2.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/net-dns/c-ares/Manifest b/net-dns/c-ares/Manifest
index 050ef35ea486..9938aee0f1a8 100644
--- a/net-dns/c-ares/Manifest
+++ b/net-dns/c-ares/Manifest
@@ -1,3 +1,5 @@
DIST c-ares-1.17.1.tar.gz 1518701 BLAKE2B 31dac21ecae231e2a201dc1ba954c1a0663a06f93eb8e7e033ca3c6d385f53e07af0b04854739f1ee8a7f0693f67f620143e152ef092b49342c62279a0480905 SHA512 b11887bcc9274d368088e1a8b6aca62414f20675cf0bc58e948f54fa04c327c39dd23cefe7509eec6397db14b550a3f6b77f5c18b3d735b3eef48ce2da1dcd00
+DIST c-ares-1.17.2.tar.gz 1538276 BLAKE2B c6f5ad65ca75f8467b624daf3caaee2f35d6e4714ce46ebe1bbf79447feecf8615915b00fa5e7bd1e97c6232864e06c53a792fbadf36a5399883529769273e24 SHA512 f625e0ef8508af6475d3e83b51ab29be8a4878e2a87e7f518bea046b76a74bfde7043ca6ec2a9e714c898ab9e5d4a5a678c3347a9f9eb68980438f7ca8ae3fc8
EBUILD c-ares-1.17.1.ebuild 903 BLAKE2B d917ecb20945f9625b9a559d3020afb1884a552163dba9fa68283456a42a838d2255624d036e3e593906ac3fc4572ce97ac1b2b06d5751ae8c5370f79ba54104 SHA512 60a88a0d054ee7d63c0015b9918684bcaaf3dd0add0a35aacdd6539406f4fdc1df254913b25c6f93e70512071643be3bb3febc352d49913ae37a7a3fd6594e62
+EBUILD c-ares-1.17.2.ebuild 1325 BLAKE2B 145b23f252ca78baa87c71d9fb9de23a7e4575fb688fc5322117843e937706f70615e6ed3bddbd33b76056ec524f58ccb33fddcb128142001fdd260f8a964f27 SHA512 cdcf66336a4f3c6824ee80110d316d956b9d2c613df244213168bc2256b3cafbe7750c86a00ead3051cea8853f6bd19bc8a6b690d265131f230d40c1d418c29c
MISC metadata.xml 339 BLAKE2B e32a823a5af6c260cfb7ebc58dfa81bcb97ff1792aca66662e8206ad3bfb5304784e2f9ec800fe1230472510f864edcacec07df97493e1b481c157e3e5fc971b SHA512 fb726c9af8f3b9b104f13f5d7f8c1d38659848afdd619fe8c9242e8d2dea24c21a2654baca4bac96a94cadf68a0f649c87346f296e6b5d2aa5d88a4276c41755
diff --git a/net-dns/c-ares/c-ares-1.17.2.ebuild b/net-dns/c-ares/c-ares-1.17.2.ebuild
new file mode 100644
index 000000000000..4db3832180f7
--- /dev/null
+++ b/net-dns/c-ares/c-ares-1.17.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="C library that resolves names asynchronously"
+HOMEPAGE="https://c-ares.haxx.se/"
+SRC_URI="https://${PN}.haxx.se/download/${P}.tar.gz"
+
+# Subslot = SONAME of libcares.so.2
+SLOT="0/2"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc64-solaris"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+DOCS=( AUTHORS CHANGES NEWS README.md RELEASE-NOTES TODO )
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/ares_build.h
+)
+
+multilib_src_configure() {
+ # Needed for running unit tests only
+ # Violates sandbox and tests pass fine without
+ ax_cv_uts_namespace=no \
+ ax_cv_user_namespace=no \
+ ECONF_SOURCE="${S}" \
+ econf \
+ --enable-nonblocking \
+ --enable-symbol-hiding \
+ $(use_enable static-libs static) \
+ $(use_enable test tests)
+}
+
+multilib_src_test() {
+ cd "${BUILD_DIR}"/test || die
+
+ # We're skipping the "real" network tests with the filter
+ # see https://github.com/c-ares/c-ares/tree/main/test
+ ./arestest --gtest_filter=-*Live* || die "arestest failed!"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ find "${ED}" -name "*.la" -delete || die
+}