summaryrefslogtreecommitdiff
path: root/net-dns/c-ares/c-ares-1.17.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/c-ares/c-ares-1.17.2.ebuild')
-rw-r--r--net-dns/c-ares/c-ares-1.17.2.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/net-dns/c-ares/c-ares-1.17.2.ebuild b/net-dns/c-ares/c-ares-1.17.2.ebuild
index 87c0e4720e40..dd99e46267ec 100644
--- a/net-dns/c-ares/c-ares-1.17.2.ebuild
+++ b/net-dns/c-ares/c-ares-1.17.2.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://${PN}.haxx.se/download/${P}.tar.gz"
# Subslot = SONAME of libcares.so.2
SLOT="0/2"
LICENSE="MIT"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc64-solaris"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc64-solaris"
IUSE="static-libs test"
RESTRICT="!test? ( test )"
@@ -40,7 +40,19 @@ multilib_src_test() {
# We're skipping the "real" network tests with the filter
# see https://github.com/c-ares/c-ares/tree/main/test
- ./arestest --gtest_filter=-*Live* || die "arestest failed!"
+ local network_tests=(
+ # Most live tests have Live in the name
+ *Live*
+ # These don't but are still in ares-test-live.cc => live
+ *GetTCPSock*
+ *TimeoutValue*
+ *GetSock*
+ *GetSock_virtualized*
+ )
+
+ # The format for disabling test1, test2, and test3 looks like:
+ # -test1:test2:test3
+ ./arestest --gtest_filter=-$(echo $(IFS=:; echo "${network_tests[*]}")) || die "arestest failed!"
}
multilib_src_install_all() {