summaryrefslogtreecommitdiff
path: root/net-dialup/sercd/sercd-3.0.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/sercd/sercd-3.0.0-r2.ebuild')
-rw-r--r--net-dialup/sercd/sercd-3.0.0-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-dialup/sercd/sercd-3.0.0-r2.ebuild b/net-dialup/sercd/sercd-3.0.0-r2.ebuild
new file mode 100644
index 000000000000..7bdbc3d3ffda
--- /dev/null
+++ b/net-dialup/sercd/sercd-3.0.0-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="RFC2217-compliant serial port redirector"
+HOMEPAGE="https://sourceforge.net/projects/sercd"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="xinetd"
+
+RDEPEND="xinetd? ( virtual/inetd )"
+
+DOCS=( AUTHORS README )
+
+src_prepare() {
+ eapply_user
+}
+
+src_install () {
+ default
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ if use xinetd ; then
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}/${PN}.xinetd" "${PN}"
+ fi
+}