summaryrefslogtreecommitdiff
path: root/net-dialup/rp-l2tp/rp-l2tp-0.4-r5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/rp-l2tp/rp-l2tp-0.4-r5.ebuild')
-rw-r--r--net-dialup/rp-l2tp/rp-l2tp-0.4-r5.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-dialup/rp-l2tp/rp-l2tp-0.4-r5.ebuild b/net-dialup/rp-l2tp/rp-l2tp-0.4-r5.ebuild
new file mode 100644
index 000000000000..550a22d585a9
--- /dev/null
+++ b/net-dialup/rp-l2tp/rp-l2tp-0.4-r5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="User-space implementation of L2TP for Linux and other UNIX systems"
+HOMEPAGE="https://sourceforge.net/projects/rp-l2tp/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+ GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gentoo.patch"
+ "${FILESDIR}/${P}-flags.patch"
+ "${FILESDIR}/${P}-build.patch"
+ "${FILESDIR}/${P}-parallel-build.patch"
+ "${FILESDIR}/${P}-clang16-build-fix.patch"
+)
+
+src_prepare() {
+ default
+
+ eautoreconf #871210
+
+ tc-export AR CC
+}
+
+src_install() {
+ emake RPM_INSTALL_ROOT="${D}" install
+ einstalldocs
+
+ newdoc l2tp.conf rp-l2tpd.conf
+
+ docinto libevent
+ dodoc -r libevent/Doc/.
+ docompress -x /usr/share/doc/${PF}/libevent
+
+ newinitd "${FILESDIR}"/rp-l2tpd-init rp-l2tpd
+}