summaryrefslogtreecommitdiff
path: root/net-dialup/accel-ppp/accel-ppp-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/accel-ppp/accel-ppp-9999.ebuild')
-rw-r--r--net-dialup/accel-ppp/accel-ppp-9999.ebuild27
1 files changed, 12 insertions, 15 deletions
diff --git a/net-dialup/accel-ppp/accel-ppp-9999.ebuild b/net-dialup/accel-ppp/accel-ppp-9999.ebuild
index 587d14401f18..82f2ef6bca74 100644
--- a/net-dialup/accel-ppp/accel-ppp-9999.ebuild
+++ b/net-dialup/accel-ppp/accel-ppp-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
LUA_COMPAT=( lua5-1 )
-
EGIT_REPO_URI="https://github.com/accel-ppp/accel-ppp.git"
-inherit cmake flag-o-matic git-r3 linux-info linux-mod lua-single
+MODULES_OPTIONAL_IUSE="ipoe"
+inherit cmake flag-o-matic git-r3 linux-mod-r1 lua-single
DESCRIPTION="High performance PPTP, PPPoE and L2TP server"
HOMEPAGE="https://sourceforge.net/projects/accel-ppp/"
@@ -15,7 +15,7 @@ SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="debug doc ipoe libtomcrypt lua postgres radius shaper snmp valgrind"
+IUSE="debug doc libtomcrypt lua postgres radius shaper snmp valgrind"
RDEPEND="!libtomcrypt? ( dev-libs/openssl:0= )
libtomcrypt? ( dev-libs/libtomcrypt:0= )
@@ -35,12 +35,8 @@ REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
valgrind? ( debug )"
pkg_setup() {
- if use ipoe; then
- linux-mod_pkg_setup
- set_arch_to_kernel
- else
- linux-info_pkg_setup
- fi
+ linux-mod-r1_pkg_setup
+ set_arch_to_kernel
use lua && lua-single_pkg_setup
}
@@ -81,15 +77,16 @@ src_configure() {
}
src_compile() {
+ local modlist=( ipoe=accel-ppp:"${BUILD_DIR}/drivers/ipoe/driver" vlan_mon=accel-ppp:"${BUILD_DIR}/drivers/vlan_mon/driver" )
+ MODULES_MAKEARGS+=(
+ KDIR="${KV_OUT_DIR}"
+ )
+ linux-mod-r1_src_compile
cmake_src_compile
}
src_install() {
- if use ipoe; then
- local MODULE_NAMES="ipoe(accel-ppp:${BUILD_DIR}/drivers/ipoe/driver) vlan_mon(accel-ppp:${BUILD_DIR}/drivers/vlan_mon/driver)"
- linux-mod_src_install
- fi
-
+ linux-mod-r1_src_install
cmake_src_install
use doc && dodoc -r rfc