summaryrefslogtreecommitdiff
path: root/net-analyzer
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/Manifest.gzbin49478 -> 49629 bytes
-rw-r--r--net-analyzer/nuttcp/Manifest6
-rw-r--r--net-analyzer/nuttcp/files/nuttcp-8.1.4-makefile.patch21
-rw-r--r--net-analyzer/nuttcp/files/nuttcp.confd5
-rw-r--r--net-analyzer/nuttcp/files/nuttcp.initd16
-rw-r--r--net-analyzer/nuttcp/metadata.xml23
-rw-r--r--net-analyzer/nuttcp/nuttcp-8.1.4.ebuild62
-rw-r--r--net-analyzer/scapy/Manifest4
-rw-r--r--net-analyzer/scapy/scapy-2.4.0_rc4.ebuild43
-rw-r--r--net-analyzer/scapy/scapy-9999.ebuild47
10 files changed, 210 insertions, 17 deletions
diff --git a/net-analyzer/Manifest.gz b/net-analyzer/Manifest.gz
index 4bb9ef843457..fd3fba705173 100644
--- a/net-analyzer/Manifest.gz
+++ b/net-analyzer/Manifest.gz
Binary files differ
diff --git a/net-analyzer/nuttcp/Manifest b/net-analyzer/nuttcp/Manifest
new file mode 100644
index 000000000000..3935f8707154
--- /dev/null
+++ b/net-analyzer/nuttcp/Manifest
@@ -0,0 +1,6 @@
+AUX nuttcp-8.1.4-makefile.patch 686 BLAKE2B 39e0b6e366858631f77e47833d9af0881a1d83a188a883401c788b991995f824780abbe47be10fc7120e32ee5254c5e044f4fdceab60b9bd6e207278b684c3f9 SHA512 58df32ebd9b2a6ca775a4a88d6387bf0552aeb8cdb65b12e99d0f7fab6139c453e130e5043d14cc5c6b9b3c10729a2233bfe8c038665a85a59d3017bd569bdfd
+AUX nuttcp.confd 174 BLAKE2B 8ca9f6f9abc473e232f650bacb989e4d3a0a3d9e40f239a70e5b7fcc016f3ad21c43f530dd0508acbdc3d5cb13cd85cbaad290c89f1227420778c2423f2815de SHA512 afc5d55e17535633606873a1db18fe560a3c7450bca6fdad3141215bcad27a0480f6ccfadbaad436c84c9bc131dae375ab5ddfd4d85cb3e1565f79f6d07bbbcb
+AUX nuttcp.initd 328 BLAKE2B 823ea8ad721e66ad26a5a1d2f43f098721fc36146524ecd3e02185b3da3bb83bad11f20eaed285da8a00289afd27d3bbc01f461e348086c8903c6f3b14d9b598 SHA512 29bf5e158955238a4579e60ae81b47e34ca620c2c69ab41667c35f626993f8c6adfb88c9f7a484551b95f1fe1c7aadb4903c951a30114ba38dc963b614b19ecd
+DIST nuttcp-8.1.4.tar.bz2 13063356 BLAKE2B 374b76bed06615bf5966df5864c8987d5e8336eedd7450ccfef164e575f58ce2a22dbc1e0327e7740799560c30a03f9423d3fd50579fa01cd638059485c7f61b SHA512 ba6ff33bc1790c92f47d760d4588b128f60f0ca09ed43d95fd10b0edfb636a493b0d26b195e688a13b5b79fafc1cc52a0c73455263f921ff8ad0cf087f1d937b
+EBUILD nuttcp-8.1.4.ebuild 1456 BLAKE2B fe278b37f5b923b27365f2f979eaae2f00324ea7b40dfa5f7f9c617546bd8f6ff0293099ff6852dcdad489ce46b8c1bce07c36c3878bec18307bc2474b9f1d1b SHA512 4726a56012dae0e6c46e012b3842bd199c31e29f7eee49c839ae2b475e44e71dab417ea3ea4b44716fe24e2409226dd12341d645f0fad45819bbc145d7e6841f
+MISC metadata.xml 915 BLAKE2B 2011a0921d4de0ce5f7d30cc149751aed2120364b7c74763970b86d67f49eebb4b1ace092fbb6a1f6583ce2b6af75db36c02355a4d74f8724c693b0d5535d825 SHA512 6e3db2f2b940e1ebff18f0bafdab669a9e67c29f4845b171c4cedd50923e5ff5e22839a4c328bf7b8f55d7ee6c5da827f48035816d7e58dda384fec9bee1c59d
diff --git a/net-analyzer/nuttcp/files/nuttcp-8.1.4-makefile.patch b/net-analyzer/nuttcp/files/nuttcp-8.1.4-makefile.patch
new file mode 100644
index 000000000000..02de62a80e70
--- /dev/null
+++ b/net-analyzer/nuttcp/files/nuttcp-8.1.4-makefile.patch
@@ -0,0 +1,21 @@
+--- a/Makefile 2017-10-29 08:39:34.209474792 +0200
++++ b/Makefile 2017-10-29 15:11:02.082490459 +0200
+@@ -2,8 +2,7 @@
+ #EXTRAVERSION=-pre1
+ CC = gcc -Wall
+ #OPT = -g -O0
+-OPT = -O3
+-CFLAGS = $(OPT) $(NOIPV6)
++CFLAGS += $(OPT) $(NOIPV6)
+ LIBS =
+ ifneq ($(NOIPV6),)
+ APPEXTV6=-noipv6
+@@ -53,7 +52,7 @@
+ # $(MAKE) CC=icc OPT="-w -O3 -parallel -unroll -align -xM -vec_report -par_report2"
+
+ $(APP)$(EXTRAVERSION)$(APPEXT): $(APP)$(EXTRAVERSION).c $(LIBS)
+- $(CC) $(CFLAGS) -o $@ $< $(LIBS)
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $< $(LIBS)
+ inet_ntop.o: missing/inet_ntop.c missing/config.h
+ $(CC) $(CFLAGS.MISSING) -o $@ -c $<
+ inet_pton.o: missing/inet_pton.c missing/config.h
diff --git a/net-analyzer/nuttcp/files/nuttcp.confd b/net-analyzer/nuttcp/files/nuttcp.confd
new file mode 100644
index 000000000000..a41d858550a1
--- /dev/null
+++ b/net-analyzer/nuttcp/files/nuttcp.confd
@@ -0,0 +1,5 @@
+# Config file for /etc/init.d/nuttcp
+
+# extra options (run nuttcp -h for a list of supported options)
+# Parameter -S indicates that nuttcp acts as a server.
+NUTTCP_OPTS="-S"
diff --git a/net-analyzer/nuttcp/files/nuttcp.initd b/net-analyzer/nuttcp/files/nuttcp.initd
new file mode 100644
index 000000000000..3ba80fab8f6e
--- /dev/null
+++ b/net-analyzer/nuttcp/files/nuttcp.initd
@@ -0,0 +1,16 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+command="/usr/bin/nuttcp"
+command_background="yes"
+command_args="${NUTTCP_OPTS}"
+pidfile="/run/${RC_SVCNAME}.pid"
+
+depend() {
+ need net
+}
+
+start_post() {
+ pgrep -n "${RC_SVCNAME%%.*}" > "${pidfile}"
+}
diff --git a/net-analyzer/nuttcp/metadata.xml b/net-analyzer/nuttcp/metadata.xml
new file mode 100644
index 000000000000..66e11db82cfd
--- /dev/null
+++ b/net-analyzer/nuttcp/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>spiderx@spiderx.dp.ua</email>
+ <name>Vladimir Pavljuchenkov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ nuttcp is a network performance measurement tool intended for use
+ by network and system managers. Its most basic usage is to determine
+ the raw TCP (or UDP) network layer throughput by transferring memory
+ buffers from a source system across an interconnecting network to
+ a destination system, either transferring data for a specified time
+ interval, or alternatively transferring a specified number of bytes.
+ </longdescription>
+ <upstream>
+ <bugs-to>mailto:nuttcp@lcp.nrl.navy.mil</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/nuttcp/nuttcp-8.1.4.ebuild b/net-analyzer/nuttcp/nuttcp-8.1.4.ebuild
new file mode 100644
index 000000000000..97c01c07adc1
--- /dev/null
+++ b/net-analyzer/nuttcp/nuttcp-8.1.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit readme.gentoo-r1 systemd toolchain-funcs
+
+DESCRIPTION="Network performance measurement tool"
+HOMEPAGE="http://www.nuttcp.net/"
+SRC_URI="http://nuttcp.net/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ipv6 xinetd"
+
+RDEPEND="xinetd? ( sys-apps/xinetd )"
+
+DOCS=( examples.txt README )
+# Honor CC, LDFLAGS, CFLAGS, CPPFLAGS
+PATCHES=( "${FILESDIR}"/"${P}"-makefile.patch )
+
+DOC_CONTENTS="Usage of nuttpc by its service name in xinetd service,
+iptables rules, etc. will require adding these lines to /etc/services:\\n
+nuttcp\\t\\t5000/tcp\\n
+nuttcp-data\\t\\t5001/tcp\\n
+nuttcp6\\t\\t5000/tcp\\n
+nuttcp6-data\\t\\t5001/tcp\\n\\n
+To run ${PN} in server mode, run:\\n/etc/init.d/${PN} start"
+
+src_prepare() {
+ default
+
+ # Fix path to binary
+ sed -i '/server/s|/local||' xinetd.d/nuttcp || die "sed failed"
+}
+
+src_compile() {
+ emake "$(usex ipv6 APPEXT='' NOIPV6=-DNO_IPV6)" CC="$(tc-getCC)"
+}
+
+src_install() {
+ einstalldocs
+ doman "${PN}".8
+ newbin "${P}$(usex ipv6 '' -noipv6)" "${PN}"
+
+ newinitd "${FILESDIR}"/"${PN}".initd "${PN}"
+ newconfd "${FILESDIR}"/"${PN}".confd "${PN}"
+ systemd_dounit systemd/"${PN}"@.service
+ systemd_dounit systemd/"${PN}".socket
+
+ if use xinetd ; then
+ insinto /etc/xinetd.d
+ doins xinetd.d/"${PN}"
+ fi
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/net-analyzer/scapy/Manifest b/net-analyzer/scapy/Manifest
index 7aa547e16783..95b3cd7dcb14 100644
--- a/net-analyzer/scapy/Manifest
+++ b/net-analyzer/scapy/Manifest
@@ -1,6 +1,8 @@
DIST scapy-2.3.2.tar.gz 1166056 BLAKE2B bce5f37bd833dc457089cdfebd2dc019c4f7bed636935b4a6b51a2cf7355f5761fadaa304e93c276daa2200c48ab0e1c0a08bd278e30dfea1faa01321a0b957e SHA512 6b15e102708d1bd0ca0c910e2d82416cd172634409f93c506542a7dc6b69ddc9c9afef6ec07929f70cc0f8f4c455cdc84d9b35bc2c5b72f79dd7e6785306dc7a
DIST scapy-2.3.3.tar.gz 1459132 BLAKE2B 442e13853cfd4bac4984571367990ce03a2fc1a634564ed7e05641130d435818f161687c530f17280a20f1063aafeeeea35cb867fc2f7d78a4f3ae257dbb6f90 SHA512 47ca2eceafe7b693c569a92c106782037d869c323aaaec41cace07dfdeb3c6a7e9f7bc8ca1150b3c0daea54e6665f93eb1dfc3c511419cfa28eb2e0753bf9ba4
+DIST scapy-2.4.0_rc4.tar.gz 2472251 BLAKE2B 720777e7d19ae1a312ccd78c6d005cf6f1f42fcac8f11956b2fb5521dac17ef477106cef2ee9a9384f764dd1aef337b010faed61f2fb34c3458b3a9c836eb4ed SHA512 003d573fb8ec83029eca93fa9f6333f9a4b4a166ab355a19339194b6a7b8a772d692afeed8d19e0f9422caae326167f1acf819319327f3495dc389fc9a2ea811
EBUILD scapy-2.3.2-r1.ebuild 897 BLAKE2B 6c39e33ab0c611135c34362038461e51e8adaef9828538782b35639a452704892d6ea6d6d1759f475bdf2a35f9b397b5ece3b390a21d73f46ef9964354e8de51 SHA512 c3dff0a0ce1e5929bde3cdecd85654f7f1e070bdff3735359714c3d5d427ca4ae9a339642573274dda1ba13ae041b483fcaf3c46b8ea70c4100685cfee7d89c8
EBUILD scapy-2.3.3.ebuild 899 BLAKE2B af30ed756c47235b49aa1a20f89e9f9f0d4fe306cc999f11e2ecc55a79bd52342ec85a743dd47b8c76d9f118cb482aa875bc057e4455a4c5b19002b16f8b77fa SHA512 85cd0bb71df5e99fd737753d13f5e33a1811c8d23e38b6bcca2493b78d27e69deb393d0e363ce43d5de4fb0d8ef042768fae5a20b117d9d7befd2052de99825a
-EBUILD scapy-9999.ebuild 798 BLAKE2B c11b548fb7034bf030e60bead05db494d793deb1ff6b97184cef73f3d6fef3a6da96885f0c2062223b1891ec9a4af252f13ad98087b78a4b6884b679ac6e8152 SHA512 a1697b2fe97f24fb201595461c81f3e0add75edd7f354a634c0fdde81a949f2bc8fb4b88fbc6a1ca1d09ac75fc01928fce6ee98b65a96f1f090066bb0a744ec2
+EBUILD scapy-2.4.0_rc4.ebuild 1052 BLAKE2B 3b3c822b646da0a135436fac328a5d486e23fede27fa2382e18b3478a2e0ce6512eba033da1976d9ae985eb53cf970499ebc5b7bb288b5e89b6ac10e4592b580 SHA512 48d72227b96a78d46e5e1e5bddbfc9824d3c40c04f83959732cb3ee98f8eb556864a2316b7bb6a8eae8539783dd7332812f06ff1c90f0714116992c1d118086c
+EBUILD scapy-9999.ebuild 1014 BLAKE2B bca076704e8490453c80ceb80873d17b78f94f0f77c9ad28fb1641674f9f5b03872ddd63421a65a89d217fb1859083e7119fba3bcc8b8480c4ad808a7642f003 SHA512 785a45b51097a15d68d8f069cd84bf6e59a1b09a3c2e970cf8d62340ce3df3c7a0a443a694a452d00f6b0cf2f8befc3c6fe5bc17379b1690013741d356044537
MISC metadata.xml 761 BLAKE2B 53a142c9861099fda37030b396c87f8cb67c4cc3672e6ef5116258759d0d4c7b2dcacee6973fd09596ae2a4f7ec6cd01b10289a8740994d5cd7ceaa78729c753 SHA512 a5d6f2cb43d82333ec33bb655b9251ec9f04a1f4718f4a54306f1938b19e75027ca62c47945d76462c1ad7f9ce7710e5df206b60962c1f9928fd82fd0272402c
diff --git a/net-analyzer/scapy/scapy-2.4.0_rc4.ebuild b/net-analyzer/scapy/scapy-2.4.0_rc4.ebuild
new file mode 100644
index 000000000000..1e5186715f7e
--- /dev/null
+++ b/net-analyzer/scapy/scapy-2.4.0_rc4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="A Python interactive packet manipulation program for mastering the network"
+HOMEPAGE="http://www.secdev.org/projects/scapy/ https://github.com/secdev/scapy"
+SRC_URI="https://github.com/secdev/${PN}/archive/v${PV/_/}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RDEPEND="
+ net-analyzer/tcpdump
+"
+S=${WORKDIR}/${P/_/}
+DOC_CONTENTS="
+Scapy has optional support for the following packages:
+
+ dev-python/cryptography
+ dev-python/gnuplot-py
+ dev-python/ipython
+ dev-python/pyx
+ dev-python/visual
+ media-gfx/graphviz
+ net-analyzer/tcpreplay
+ virtual/imagemagick-tools
+
+ See also ${EPREFIX}/usr/share/doc/${PF}/installation.rst
+"
+
+src_prepare() {
+ echo ${PV/_/} > ${PN}/VERSION
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc -r doc/${PN}/*
+ DISABLE_AUTOFORMATTING=plz readme.gentoo_create_doc
+}
diff --git a/net-analyzer/scapy/scapy-9999.ebuild b/net-analyzer/scapy/scapy-9999.ebuild
index 7d971be6c7c6..ab2b39168b26 100644
--- a/net-analyzer/scapy/scapy-9999.ebuild
+++ b/net-analyzer/scapy/scapy-9999.ebuild
@@ -1,28 +1,43 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils distutils-r1 git-r3
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit distutils-r1 git-r3 readme.gentoo-r1
DESCRIPTION="A Python interactive packet manipulation program for mastering the network"
-HOMEPAGE="http://www.secdev.org/projects/scapy/"
+HOMEPAGE="http://www.secdev.org/projects/scapy/ https://github.com/secdev/scapy"
EGIT_REPO_URI="https://github.com/secdev/${PN}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="gnuplot pyx crypt graphviz imagemagick visual tcpreplay"
-
RDEPEND="
net-analyzer/tcpdump
- gnuplot? ( dev-python/gnuplot-py[${PYTHON_USEDEP}] )
- pyx? ( dev-python/pyx[${PYTHON_USEDEP}] )
- crypt? ( dev-python/pycrypto[${PYTHON_USEDEP}] )
- graphviz? ( media-gfx/graphviz )
- imagemagick? ( virtual/imagemagick-tools )
- visual? ( dev-python/visual )
- tcpreplay? ( net-analyzer/tcpreplay )
"
+S=${WORKDIR}/${P/_/}
+DOC_CONTENTS="
+Scapy has optional support for the following packages:
+
+ dev-python/cryptography
+ dev-python/gnuplot-py
+ dev-python/ipython
+ dev-python/pyx
+ dev-python/visual
+ media-gfx/graphviz
+ net-analyzer/tcpreplay
+ virtual/imagemagick-tools
+
+ See also ${EPREFIX}/usr/share/doc/${PF}/installation.rst
+"
+
+src_prepare() {
+ echo ${PV/_/} > ${PN}/VERSION
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc -r doc/${PN}/*
+ DISABLE_AUTOFORMATTING=plz readme.gentoo_create_doc
+}