summaryrefslogtreecommitdiff
path: root/net-analyzer/wireshark/wireshark-4.2.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/wireshark/wireshark-4.2.5.ebuild')
-rw-r--r--net-analyzer/wireshark/wireshark-4.2.5.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/net-analyzer/wireshark/wireshark-4.2.5.ebuild b/net-analyzer/wireshark/wireshark-4.2.5.ebuild
index 0e0d86d74067..ef484db79a7e 100644
--- a/net-analyzer/wireshark/wireshark-4.2.5.ebuild
+++ b/net-analyzer/wireshark/wireshark-4.2.5.ebuild
@@ -24,7 +24,7 @@ else
S="${WORKDIR}/${P/_/}"
if [[ ${PV} != *_rc* ]] ; then
- KEYWORDS="~amd64 ~arm64 ~hppa"
+ KEYWORDS="amd64 ~arm arm64 ~hppa ~x86"
fi
fi
@@ -141,6 +141,7 @@ fi
PATCHES=(
"${FILESDIR}"/${PN}-2.6.0-redhat.patch
+ "${FILESDIR}"/${PN}-4.2.5-http2-test.patch
)
python_check_deps() {
@@ -203,6 +204,9 @@ src_configure() {
-DPython3_EXECUTABLE="${PYTHON}"
-DCMAKE_DISABLE_FIND_PACKAGE_{Asciidoctor,DOXYGEN}=$(usex !doc)
+ # Force bundled lemon (bug 933119)
+ -DLEMON_EXECUTABLE=
+
$(use androiddump && use pcap && echo -DEXTCAP_ANDROIDDUMP_LIBPCAP=yes)
$(usex gui LRELEASE=$(qt5_get_bindir)/lrelease '')
$(usex gui MOC=$(qt5_get_bindir)/moc '')
@@ -269,11 +273,6 @@ src_configure() {
src_test() {
cmake_build test-programs
- EPYTEST_DESELECT=(
- # TODO: investigate
- suite_follow_multistream.py::case_follow_multistream::test_follow_http2_multistream
- )
-
# https://www.wireshark.org/docs/wsdg_html_chunked/ChTestsRunPytest.html
epytest \
--disable-capture \