summaryrefslogtreecommitdiff
path: root/net-analyzer/wireshark/wireshark-3.6.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/wireshark/wireshark-3.6.13.ebuild')
-rw-r--r--net-analyzer/wireshark/wireshark-3.6.13.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/net-analyzer/wireshark/wireshark-3.6.13.ebuild b/net-analyzer/wireshark/wireshark-3.6.13.ebuild
index 0e8916b20943..1e4730af8694 100644
--- a/net-analyzer/wireshark/wireshark-3.6.13.ebuild
+++ b/net-analyzer/wireshark/wireshark-3.6.13.ebuild
@@ -4,7 +4,7 @@
EAPI=8
LUA_COMPAT=( lua5-{1..2} )
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit fcaps flag-o-matic lua-single python-any-r1 qmake-utils xdg cmake
@@ -32,7 +32,9 @@ IUSE+=" sdjournal test +text2pcap tfshark +tshark +udpdump zlib +zstd"
REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
plugin-ifdemo? ( plugins qt5 )"
-RESTRICT="!test? ( test )"
+# Tests restricted for now because rely on pytest internals w/ >=3.11
+# See bug #897078 and https://gitlab.com/wireshark/wireshark/-/issues/18740.
+RESTRICT="!test? ( test ) test"
# bug #753062 for speexdsp
RDEPEND="acct-group/pcap