summaryrefslogtreecommitdiff
path: root/net-analyzer/wireshark/files
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/wireshark/files')
-rw-r--r--net-analyzer/wireshark/files/wireshark-2.4-androiddump.patch8
-rw-r--r--net-analyzer/wireshark/files/wireshark-99999999-about_dialog-plugins_add_description.patch18
-rw-r--r--net-analyzer/wireshark/files/wireshark-99999999-androiddump-wsutil.patch8
3 files changed, 26 insertions, 8 deletions
diff --git a/net-analyzer/wireshark/files/wireshark-2.4-androiddump.patch b/net-analyzer/wireshark/files/wireshark-2.4-androiddump.patch
index e67ab21b6a8d..2272ef891c27 100644
--- a/net-analyzer/wireshark/files/wireshark-2.4-androiddump.patch
+++ b/net-analyzer/wireshark/files/wireshark-2.4-androiddump.patch
@@ -1,7 +1,7 @@
--- a/extcap/androiddump.c
+++ b/extcap/androiddump.c
-@@ -363,13 +363,13 @@
- pcap = pcap_open_dead_with_tstamp_precision(encap_ext, PACKET_LENGTH, PCAP_TSTAMP_PRECISION_NANO);
+@@ -438,13 +438,13 @@
+ pcap = pcap_open_dead_with_tstamp_precision(encap, PACKET_LENGTH, PCAP_TSTAMP_PRECISION_NANO);
extcap_dumper.dumper.pcap = pcap_dump_open(pcap, fifo);
if (!extcap_dumper.dumper.pcap) {
- g_warning("Can't open %s for saving packets: %s", pcap_geterr(pcap));
@@ -15,8 +15,8 @@
+ g_warning("Write to %s failed: %s", fifo, g_strerror(errno));
}
#else
- int err = 0;
-@@ -416,7 +416,7 @@
+ wtap_dump_params params = WTAP_DUMP_PARAMS_INIT;
+@@ -480,7 +480,7 @@
pcap_dump((u_char *) extcap_dumper.dumper.pcap, &pcap_header, buffer);
if (pcap_dump_flush(extcap_dumper.dumper.pcap) == -1) {
diff --git a/net-analyzer/wireshark/files/wireshark-99999999-about_dialog-plugins_add_description.patch b/net-analyzer/wireshark/files/wireshark-99999999-about_dialog-plugins_add_description.patch
new file mode 100644
index 000000000000..5506c6ec2ad4
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-99999999-about_dialog-plugins_add_description.patch
@@ -0,0 +1,18 @@
+--- a/ui/qt/about_dialog.cpp
++++ b/ui/qt/about_dialog.cpp
+@@ -112,7 +112,6 @@ QStringList AuthorListModel::headerColumns() const
+ return QStringList() << tr("Name") << tr("Email");
+ }
+
+-#if defined(HAVE_PLUGINS) || defined(HAVE_LUA)
+ static void plugins_add_description(const char *name, const char *version,
+ const char *types, const char *filename,
+ void *user_data)
+@@ -121,7 +120,6 @@ static void plugins_add_description(const char *name, const char *version,
+ QStringList plugin_row = QStringList() << name << version << types << filename;
+ *plugin_data << plugin_row;
+ }
+-#endif
+
+ PluginListModel::PluginListModel(QObject * parent) : AStringListListModel(parent)
+ {
diff --git a/net-analyzer/wireshark/files/wireshark-99999999-androiddump-wsutil.patch b/net-analyzer/wireshark/files/wireshark-99999999-androiddump-wsutil.patch
index 9715de676f16..3d3a2a9c9323 100644
--- a/net-analyzer/wireshark/files/wireshark-99999999-androiddump-wsutil.patch
+++ b/net-analyzer/wireshark/files/wireshark-99999999-androiddump-wsutil.patch
@@ -1,15 +1,15 @@
--- a/extcap/CMakeLists.txt
+++ b/extcap/CMakeLists.txt
-@@ -68,6 +68,8 @@
+@@ -91,6 +91,8 @@ if(BUILD_androiddump)
if(HAVE_LIBPCAP)
set(androiddump_LIBS
ui
+ wiretap
+ wsutil
${GLIB2_LIBRARIES}
- ${PCAP_LIBRARIES}
- )
-@@ -78,6 +80,7 @@
+ ${WIN_WS2_32_LIBRARY}
+ $<$<BOOL:${PCAP_FOUND}>:pcap::pcap>
+@@ -102,6 +104,7 @@ if(BUILD_androiddump)
set(androiddump_LIBS
ui
wiretap