summaryrefslogtreecommitdiff
path: root/net-analyzer/wapiti/wapiti-3.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/wapiti/wapiti-3.0.2.ebuild')
-rw-r--r--net-analyzer/wapiti/wapiti-3.0.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/wapiti/wapiti-3.0.2.ebuild b/net-analyzer/wapiti/wapiti-3.0.2.ebuild
new file mode 100644
index 000000000000..d43c24730794
--- /dev/null
+++ b/net-analyzer/wapiti/wapiti-3.0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_REQ_USE='xml'
+
+inherit distutils-r1
+
+MY_P=${PN}3-${PV}
+DESCRIPTION="Web-application vulnerability scanner"
+HOMEPAGE="http://wapiti.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kerberos ntlm test"
+
+DEPEND="test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )"
+RDEPEND="dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.2.3[${PYTHON_USEDEP}]
+ dev-python/tld[${PYTHON_USEDEP}]
+ dev-python/yaswfp[${PYTHON_USEDEP}]
+ kerberos? ( dev-python/requests-kerberos[${PYTHON_USEDEP}] )
+ ntlm? ( dev-python/requests-ntlm[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ sed -e 's/"pytest-runner"//' -i setup.py || die
+ distutils-r1_python_prepare_all
+}