summaryrefslogtreecommitdiff
path: root/net-analyzer/thrulay/thrulay-0.9-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/thrulay/thrulay-0.9-r1.ebuild')
-rw-r--r--net-analyzer/thrulay/thrulay-0.9-r1.ebuild34
1 files changed, 22 insertions, 12 deletions
diff --git a/net-analyzer/thrulay/thrulay-0.9-r1.ebuild b/net-analyzer/thrulay/thrulay-0.9-r1.ebuild
index f66426aacee5..388b9ba4e265 100644
--- a/net-analyzer/thrulay/thrulay-0.9-r1.ebuild
+++ b/net-analyzer/thrulay/thrulay-0.9-r1.ebuild
@@ -1,30 +1,40 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit toolchain-funcs autotools
+EAPI=7
+
+inherit autotools
DESCRIPTION="Measure the capacity of a network by sending a bulk TCP stream over it"
HOMEPAGE="http://www.internet2.edu/~shalunov/thrulay/"
-SRC_URI="http://www.internet2.edu/~shalunov/thrulay/${P}.tar.gz
- mirror://sourceforge/${PN}/${P}.tar.gz"
+SRC_URI="
+ http://www.internet2.edu/~shalunov/thrulay/${P}.tar.gz
+ mirror://sourceforge/${PN}/${P}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
-DEPEND=""
src_prepare() {
- echo 'thrulay thrulayd: libthrulay.la' >>src/Makefile.am
+ default
+
+ echo 'thrulay thrulayd: libthrulay.la' >> src/Makefile.am || die
eautoreconf
}
+src_configure() {
+ econf --disable-static
+}
+
src_install() {
- emake install DESTDIR="${D}"
- #dobin src/thrulay || die "dobin failed"
- #dosbin src/thrulayd || die "dosbin failed"
- dodoc LICENSE README TODO doc/thrulay-protocol.txt
+ default
+
+ dodoc doc/thrulay-protocol.txt
doman doc/thrulay*.[1-8]
+
newinitd "${FILESDIR}"/thrulayd-init.d thrulayd
newconfd "${FILESDIR}"/thrulayd-conf.d thrulayd
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}