summaryrefslogtreecommitdiff
path: root/net-analyzer/tcpreplay
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/tcpreplay')
-rw-r--r--net-analyzer/tcpreplay/Manifest3
-rw-r--r--net-analyzer/tcpreplay/files/tcpreplay-4.4.2-configure-clang16.patch60
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-4.4.2-r1.ebuild (renamed from net-analyzer/tcpreplay/tcpreplay-4.4.2.ebuild)1
3 files changed, 63 insertions, 1 deletions
diff --git a/net-analyzer/tcpreplay/Manifest b/net-analyzer/tcpreplay/Manifest
index b7549ffd9b39..140534b2a7bf 100644
--- a/net-analyzer/tcpreplay/Manifest
+++ b/net-analyzer/tcpreplay/Manifest
@@ -1,5 +1,6 @@
AUX tcpreplay-4.3.0-enable-pcap_findalldevs.patch 333 BLAKE2B 1beb39a7263bf8491998760e4a62ac8908300e28c43500812d37d2512f9d63fcd175b93c1b384e03e9570e741dd95dea09ead017a014a4b62b3449833fe9b248 SHA512 3d035736c0656f6ace85b45af595866e06c8464641023e9d1606c288e598cde18eb96b1be8300514f6f31bc83756ae76b436402666036456571201ca38fe5026
+AUX tcpreplay-4.4.2-configure-clang16.patch 1913 BLAKE2B ab0413d0cd3677b91fa9987a63faf1e41d305a8ff275538fd1a2c6e10829bd66ecb518b3795691779202081cfc431f7d76692c2247b0ddc09becfd6550da8a60 SHA512 1cc0a9b847b90a56942041c36c0f1e9eef747fd9b2dd2e51440c13e53baf5b91d1be40460739551a0ab49ef7346a36eb76389ca8db445a2e3fda7b5da004da23
DIST tcpreplay-4.4.2.tar.xz 750592 BLAKE2B c1f0bad69eca7e086aeb7100c4a35e2984a81412f81eaf981d969d24510736788e4657b511308b38ffbf88021c23272c51b9265eb2fb08318352d3eb8bed0a2a SHA512 78e5482c0cd70a55aa80167c602b33811fa01203860fab4b2d504da71a95e218356ea0cc85254e12be7cb13b611487a150f13df94f9da274661f71e921bd6045
-EBUILD tcpreplay-4.4.2.ebuild 2131 BLAKE2B a6c8a42e51fec6bed9bc92b3bb61edccd9667795ae498fb3ab8a8d11478266f8163fc1d369c6ca0552d7c8fd09165e662643e7ed6133931c9739b18965fe3461 SHA512 4b4593adf596a1af17822997b300edd75175f3662d47d34d14459db54ac773a212c661ae48d6d74923d5650da6df7402d6aa341fb94a2ebb4712f7863237546c
+EBUILD tcpreplay-4.4.2-r1.ebuild 2182 BLAKE2B 73d268dc758ea86b4d89e4173730b81195d351cbfe7722c9e27eab991047cd51c3f1c410af2b3217e70df876eff2ad7947b786c40c299f34fe5f01669f4cc50f SHA512 1f41a2773b5b44f58ec4ccee64908dd3db27d0aea06932d97fb94709f56cd656a880b137a7cbbb0ea899833f099464be5c23b10f87ad51e021f27a2a64c03586
EBUILD tcpreplay-9999.ebuild 2133 BLAKE2B 24055b46b8746954e05cfaf88695389ef7e17171ba16f4b6de166f40e23ce3a7ef5f82f2915fc016bd6cc637ecf473fc90ed791111e87e7d905f83d0ca380629 SHA512 033159087ec5edb13a1c87a94489ffcf30b085b58707581b1de8d5f176511204a1e907e19c70b1aa46ec81678c0cb16b7bf086eb4d6c0f0562a6d74218d02718
MISC metadata.xml 1117 BLAKE2B f269c4d3da94e3fb52ad80b840c6d5b8d4acb0181dd1c370bedd88bcf75e6933f21f304f3ed5435dc601978acbef6396410d9beb96e4ec1ba1a7a53458b540c9 SHA512 bff9425e1ae71f5d106a5b2c844591db726192f356f54c6347fb9a6c10fef6b7b11cc59695b4f712d87f0359112b98ec514ce481fd824d6e343975631b105ea5
diff --git a/net-analyzer/tcpreplay/files/tcpreplay-4.4.2-configure-clang16.patch b/net-analyzer/tcpreplay/files/tcpreplay-4.4.2-configure-clang16.patch
new file mode 100644
index 000000000000..81a5a0086958
--- /dev/null
+++ b/net-analyzer/tcpreplay/files/tcpreplay-4.4.2-configure-clang16.patch
@@ -0,0 +1,60 @@
+https://github.com/appneta/tcpreplay/pull/757
+
+From 096197e584ebb7d646eef75e5a8654f7192a0af2 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Thu, 24 Nov 2022 07:30:28 +0100
+Subject: [PATCH] configure.ac: Avoid implicit int, implicit function
+ declarations
+
+Do not call exit without declaring it. Add #include <unistd.h>
+for fork. Add missing int type to the definition of main.
+
+Implicit ints and implicit function declarations were removed from
+C in 1999 and will not be supported by future compilers.
+--- a/configure.ac
++++ b/configure.ac
+@@ -1681,8 +1681,8 @@ int
+ main (int argc, char *argv[])
+ {
+ if (strncmp(PCAPNAV_VERSION, PCAPNAV_TEST, 3) >= 0)
+- exit(0);
+- exit(1);
++ return 0;
++ return 1;
+ } ]])],[libpcapnav_ver=yes
+ AC_MSG_RESULT(>= 0.4)],[libpcapnav_ver=no
+ AC_MSG_RESULT(< 0.4)],[libpcapnav_ver=no
+@@ -1726,26 +1726,27 @@ case "$host_os" in
+ #include <sys/types.h>
+ #include <sys/wait.h>
+ #include <stdio.h>
++ #include <unistd.h>
+ unsigned char a[[5]] = { 1, 2, 3, 4, 5 };
+- main() {
++ int main() {
+ unsigned int i;
+ pid_t pid;
+ int status;
+ /* avoid "core dumped" message */
+ pid = fork();
+ if (pid < 0)
+- exit(2);
++ return 2;
+ if (pid > 0) {
+ /* parent */
+ pid = waitpid(pid, &status, 0);
+ if (pid < 0)
+- exit(3);
+- exit(!WIFEXITED(status));
++ return 3;
++ return !WIFEXITED(status);
+ }
+ /* child */
+ i = *(unsigned int *)&a[[1]];
+ printf("%d\n", i);
+- exit(0);
++ return 0;
+ }
+ EOF
+ ${CC-cc} -o conftest $CFLAGS $CPPFLAGS $LDFLAGS \
+
diff --git a/net-analyzer/tcpreplay/tcpreplay-4.4.2.ebuild b/net-analyzer/tcpreplay/tcpreplay-4.4.2-r1.ebuild
index aebdcc9142d9..2cc1e8f862c3 100644
--- a/net-analyzer/tcpreplay/tcpreplay-4.4.2.ebuild
+++ b/net-analyzer/tcpreplay/tcpreplay-4.4.2-r1.ebuild
@@ -39,6 +39,7 @@ DOCS=( docs/{CHANGELOG,CREDIT,HACKING,TODO} )
PATCHES=(
"${FILESDIR}"/${PN}-4.3.0-enable-pcap_findalldevs.patch
+ "${FILESDIR}"/${PN}-4.4.2-configure-clang16.patch
)
src_prepare() {