summaryrefslogtreecommitdiff
path: root/net-analyzer/snmptt
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/snmptt')
-rw-r--r--net-analyzer/snmptt/Manifest4
-rw-r--r--net-analyzer/snmptt/snmptt-1.4.2.ebuild60
-rw-r--r--net-analyzer/snmptt/snmptt-1.4.ebuild52
3 files changed, 62 insertions, 54 deletions
diff --git a/net-analyzer/snmptt/Manifest b/net-analyzer/snmptt/Manifest
index 78680d7d665c..8d5178e28002 100644
--- a/net-analyzer/snmptt/Manifest
+++ b/net-analyzer/snmptt/Manifest
@@ -1,4 +1,4 @@
AUX snmptt.initd-r1 374 BLAKE2B fa18e20e2fd206aacb782da948e6b2a6dcfa5f33f3f9f9f1e682a3ec1d6c058b94e0e9046f0a5a274fbf933fb47a80e00a4247a53368a18f3faa872dac2d6e04 SHA512 ccf4441135f4a8f3fb323efd68c75b099977c1855ac5ae41adf6ef2974e0c2c1fd57c132e9877da12c34683b2bf19d4774e7aad4527e530ce48ec3fb59c2b7aa
-DIST snmptt_1.4.tgz 148504 BLAKE2B b49e51d0ec207f1250536010e6475649eeca1a89f85bf31e1a7545cae2fa6ac66951916932863543336bb63a8519f35e9c54e7c67bcd14a43ed7ce6d8d63876b SHA512 200ebe565766c15f85b9b9cbc178baeef740663efc951af4c790c4b28d27398c14a95c4b38306ec3503cefe9b86634d5f24ec5f2482694f07789e9025ea39a80
-EBUILD snmptt-1.4.ebuild 1215 BLAKE2B edf2cd62de24976f6d4391f0c5fde21d3627651c4fa1cce0361900c526512fc50b3e97023915184e575e636b8733db931725f0a026a315226fa74c110d3155ef SHA512 e1f60bccd817decdf4ce2aed6be0aa3ff06ec983f3c5bb6046636f70231054eaab0642b9194232a4da830bd2d3020d8e29a565ef3feba812b035494aa9b53190
+DIST snmptt_1.4.2.tgz 142697 BLAKE2B 5603197adb919a8e34d07d6981f35ff60db5674f254ce3ac4e9e12f7aad31b4ba85ddfa5b785df0c759bd97929a24e9f694b9511d060fc94d60fe2e70764c662 SHA512 b8782aa5789227253c1b65c98771de7eba319f1f29b56224415f89d0c687515cd099f0ba7d0e304d43a9d054fa66335fe09d99545f50415745ac86b8b56a2b9d
+EBUILD snmptt-1.4.2.ebuild 1140 BLAKE2B 83449b545ecb3253adb4f3ac32f04a3b10932fb4afd6fc098d912e30163260c4e607e32635fd5aa4ddc35991c204548c6ad9ba5c8d7f07d319bc49a7a578ba8f SHA512 fefccde750402f865499fbe32bd09fbaedf75b31f3f9a594317c210242f42d30eaa74c224ea7ce42c03d7c96d6093588ff1175a77a564d203d3945f0b5093a72
MISC metadata.xml 413 BLAKE2B c84c68487407401218116505b51d3e61edfbdfdd9008a83c51c2685b1ebd513fe94beedf8c02330bf465f979b5f7d88f1e3b896c8d0dea74c1a2db3795024b5a SHA512 facfbb9f61e391c7c80e3dc62300049a3fee43c2de84805474662e4c7fa7fce78ecbf86bbb691f13ddf39b0759ba5daec5feef91bedda39731d6fb389e4df1a3
diff --git a/net-analyzer/snmptt/snmptt-1.4.2.ebuild b/net-analyzer/snmptt/snmptt-1.4.2.ebuild
new file mode 100644
index 000000000000..027b00ad2231
--- /dev/null
+++ b/net-analyzer/snmptt/snmptt-1.4.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="SNMP Trap Translator"
+SRC_URI="mirror://sourceforge/snmptt/${P/-/_}.tgz"
+HOMEPAGE="http://www.snmptt.org/"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~ppc x86"
+SLOT="0"
+
+S="${WORKDIR}/${P/-/_}"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Config-IniFiles
+ net-analyzer/net-snmp
+"
+
+src_prepare() {
+ default
+
+ # bug 105354, daemonize by default
+ sed -i \
+ -e 's:mode = standalone:mode = daemon:g' \
+ -e '/pid_file/s:/var/run:/run:g' \
+ snmptt.ini || die
+
+ echo "traphandle default /usr/sbin/snmptt" > examples/snmptrapd.conf.sample || die
+}
+
+src_install() {
+ into /usr
+ dosbin \
+ snmptt \
+ snmptt-net-snmp-test \
+ snmpttconvert \
+ snmpttconvertmib \
+ snmptthandler \
+ snmptthandler-embedded
+
+ insinto /etc/snmp
+ doins \
+ examples/snmptrapd.conf.sample \
+ examples/snmptt.conf.generic \
+ snmptt.ini
+ newins examples/snmptt.conf.generic snmptt.conf
+
+ dodoc ChangeLog README sample-trap
+
+ docinto html
+ dodoc docs/*
+
+ newinitd "${FILESDIR}"/snmptt.initd-r1 snmptt
+
+ insinto /etc/logrotate.d
+ newins snmptt.logrotate snmptt
+}
diff --git a/net-analyzer/snmptt/snmptt-1.4.ebuild b/net-analyzer/snmptt/snmptt-1.4.ebuild
deleted file mode 100644
index ed70054e6dc9..000000000000
--- a/net-analyzer/snmptt/snmptt-1.4.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-MY_P="${P/-/_}"
-
-DESCRIPTION="SNMP Trap Translator"
-SRC_URI="mirror://sourceforge/snmptt/${MY_P}.tgz"
-HOMEPAGE="http://www.snmptt.org/"
-LICENSE="GPL-2"
-
-KEYWORDS="~amd64 ~ppc x86"
-SLOT="0"
-IUSE="mysql postgres"
-
-S="${WORKDIR}/${MY_P}"
-
-RDEPEND="
- dev-lang/perl
- dev-perl/Config-IniFiles
- net-analyzer/net-snmp
- mysql? ( dev-perl/DBD-mysql )
- postgres? ( dev-perl/DBD-Pg )
-"
-
-src_prepare() {
- # bug 105354, daemonize this thing
- sed -i \
- -e 's:mode = standalone:mode = daemon:g' \
- -e '/pid_file/s:/var/run:/run:g' \
- snmptt.ini || die
-
- echo "traphandle default /usr/sbin/snmptt" >examples/snmptrapd.conf.sample
-}
-
-src_install() {
- into /usr
- dosbin snmptt snmptthandler snmptt-net-snmp-test snmpttconvert \
- snmpttconvertmib
-
- insinto /etc/snmp
- doins snmptt.ini examples/snmptt.conf.generic \
- examples/snmptrapd.conf.sample
- newins examples/snmptt.conf.generic snmptt.conf
-
- dodoc BUGS ChangeLog README sample-trap
- dohtml docs/faqs.html docs/index.html docs/layout1.css docs/snmptt.html \
- docs/snmpttconvert.html docs/snmpttconvertmib.html
-
- newinitd "${FILESDIR}"/snmptt.initd-r1 snmptt
-}