summaryrefslogtreecommitdiff
path: root/net-analyzer/scli/scli-0.4.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/scli/scli-0.4.0-r2.ebuild')
-rw-r--r--net-analyzer/scli/scli-0.4.0-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-analyzer/scli/scli-0.4.0-r2.ebuild b/net-analyzer/scli/scli-0.4.0-r2.ebuild
new file mode 100644
index 000000000000..639430aa572e
--- /dev/null
+++ b/net-analyzer/scli/scli-0.4.0-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="SNMP Command Line Interface"
+HOMEPAGE="https://github.com/schoenw/scli"
+SRC_URI="ftp://ftp.ibr.cs.tu-bs.de/pub/local/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2
+ net-libs/gnet
+ net-libs/gsnmp
+ sys-libs/ncurses
+ sys-libs/readline
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-configure.patch )
+
+DOCS=( AUTHORS ChangeLog NEWS PORTING README TODO )
+
+src_prepare() {
+ default
+ eautoreconf
+}